Error connecting to environment (HTTPS connection)

Hello, I recently got this pop up screen when I want to switch environment


here is the pop up screen I got since yesterday


is there any suggestion to fix the problem? I'm the only one who got this error message, while the others not getting this kinda pop up screen. Recently I'm using service studio on version (10.0.815.0) 



Regards,

Andre Budiman

Solution

If it's only you facing this, I would suggest something:


DISCLAIMER: DO AT YOUR OWN RISK.


Now that I've got your attention, try renaming the "Service Studio 10" folder on:


C:\Users\<your user>\AppData\Local\OutSystems


To something like Service Studio 10 - BAK and see start the Service Studio. See if it fixes.


My folder looks like this:



Let me know if this helps!


Cheers

Solution

Hi Armando, 

We had the exact same issue and your solution worked perfectly, 

Thanks

I too was receiving this error running Service Studio 10.

I isolated the issue with the help of above posts to the configuration file %TEMP%\OutSystems\ServiceStudio 10.0\Settings.xml.

For some reason, the HasSSL value had changed to false for my connection. Changing this to true resolved the issue.

<MruServerTypeCache>
    <Host>
      <HostName>www.myserver.com</HostName>
      <PortNumber xsi:nil="true" />
    </Host>
    <IsJava>false</IsJava>
    <HasSSL>true</HasSSL>
    <CreatedOn>2018-12-03T10:42:07.2156014+11:00</CreatedOn>
  </MruServerTypeCache>

Yep, I am on running version 11.5.45 and the solution worked fine for me as well. (rename the foder)..


Thanks


Cheers!

Hello.


We have the same problem on version 11.6.13.

We are using a Virtual Machine from the customer that connects to the OS server.

The approach of changing the Service Studio folder name didn't worked; 

and the other solution of changing the property HasSSL to true: when we start the Service Studio IDE the property HasSSL goes again to false.


Any ideas?

Is there any solution on the question from Gonçalo José? I have now exactly the same problem in 11.6.24. Rename is no solution.

Changing HasSSL to true is no solution and afterwards the value is put to false again, somehow.

Extra information:

- I try to reach DEV, I can go to the other environments

- my colleagues can go to DEV, I'm just starting to work in the team

- with the same environment/user/pw i can go to ServiceCenter, if I use these in Service Studio it will give the error

- if my collegue logges in on my laptop with his account (which gives no problem on his laptop), he also gets the error 

- If I log in on the laptop of my collegue the connection is ok