[OfficeUtils] Cant generate from .doc or if I generate from .docx it gets messy

[OfficeUtils] Cant generate from .doc or if I generate from .docx it gets messy

  
Forge Component
(21)
Published on 2017-04-26 by Elena Novozhilova
21 votes
Published on 2017-04-26 by Elena Novozhilova

Hi all,

Im using this component

Forge

We are using version 9, so we downloaded the latest version for 9 which is Version 2.2.6.

The problem is that when I try to generate a word document from a .doc I get the following error:

'Wrong Local header signature: 0xE011CFD0'

So I tried to convert the .doc to .docx and then I tried to generate again and got no errors but the generated .docx is all messy. The text from the original word is OK! But it seems that some Boxes ( objects ), line spacing and visual elements are missing,


Anyone of you had this kind of issue? As I can see I can only upload one file here so I uploaded the generated file. If you want I can reply with the original .doc


Thanks in advance,

Vincent Colpa

any magical sugestion? other component maybe? 


cheers

Hi Vincent, 

What worked for me is to set the default Design settings in word to something that you like. (see attached image).

In my case this was the perfect override for the line spacing issue I had!




Regards,

Kommer-Jan