How to avoid black and blue screen before loading of Login screen?

How to avoid black and blue screen before loading of Login screen?

  

Hi

I am using cordova plugin to check the version, we have developed the functionalities and working as expected, Generated the app of the same. 

Now, when we are opening the application in the devices, we have encountered the following issues

1. In Android device (version:6.0, 5.1 and 8.0) for testing, the loading of splash screen is taking 5-8 seconds.

2. Before loading the splash screen, we are getting the blank grey, blue screen for around 3- 5 secs.

3. Even when tested in the ios we have encountered the same issues.

Please guide us on resolving the same.

Hello Vignesh.

Indeed, taking 5-8 secs to load is too long.

What are you doing in the OnInitialize and OnReady? Are you synchronising? Are you doing any kind of "data processing"? 

An empty app (one that does nothing) also takes this long to load?

Cheers.

Eduardo Jauch wrote:

Hello Vignesh.

Indeed, taking 5-8 secs to load is too long.

What are you doing in the OnInitialize and OnReady? Are you synchronising? Are you doing any kind of "data processing"? 

An empty app (one that does nothing) also takes this long to load?

Cheers.

Hi Edurado,

I am checking the app version in the on ready action with the use of "Check app version plugin" and "Cordova plugin"

Its taking too long time to load the splash screen and showing Black and Blue color screens, before showing the splash screen.

Thanks,

Vignesh Balasubramanian

Hello Vignesh, 

Those two screens (black and then white/blue) that show up before your app is loaded can be replaced by a customized "native" splash screen. Check how to do it in the documentation.

Your app will then have 2 splash screens: 

  • The custom native splash screen that shows up before your app is fully loaded
  • The splash screen that shows up after (the one you already have)