[Google Maps Mobile] Problem with google maps in IOS

[Google Maps Mobile] Problem with google maps in IOS

  
Forge Component
(13)
Published on 11 Oct by Labs
13 votes
Published on 11 Oct by Labs

Hi to all.

I'm developing an app for android and ios.

This app work with google maps mobile plugin, and works fine in android and outsystems emulator for web, but in ios, the map is like frozen. But when i drag into map, the markers and map show fine.

Could anyone help me?

Thanks to all.

Hi Alberto,

Can you provide an .oml replicating the behavior?

Cheers

Hi Henrique,


I'm sorry but this app is for a client and i can't share .oml file. 


I attach the image in iphone. The markers is drawing, but the map is blank until drag inside.


Thank you.



Hi Alberto,

Do you use the Map Block or the SingleLocationMap Block? If the former, have you specified the CenterLatitude and CenterLongitude Parameters? If the latter, have you specified either the Address Parameter or the Latitude and Longitude Parameters?

Adding on @Kilian post,

do you have a default zoom? 

It's hard to tell without an example, just pointing out the usual issues.


Hi Kilian,


I use the Map Block.

I share you the properties.


CenterLatitude and CenterLongitude is asigned by logic, in MapInitialized event. In android is working.


Thanks so much.


Henrique Batista wrote:

Adding on @Kilian post,

do you have a default zoom? 

It's hard to tell without an example, just pointing out the usual issues.


Thanks Henrique, 


I'm so sorry but the client does not allow me to share the .oml file.


I can share you all information that you need it.


Thanks.


Solution

Hi Alberto,

Could you try to assign a valid CenterLatitude and CenterLongitude anyway and see whether that helps?

Solution

Yes, makes total sense.

I was asking if you can build an example aside where we'll be able to reproduce the behavior.


Kilian Hekhuis wrote:

Hi Alberto,

Could you try to assign a valid CenterLatitude and CenterLongitude anyway and see whether that helps?

Hi Kilian,


I'm trying with the same result.


I'm use multiple  maps  blocks in others screens:

 - with centerlatitude and centerlongitude valid.

 - with zoom.

 -  just with apy key value.

I'm confusing because when i drag the map, this show fine.


Thanks


Henrique Batista wrote:

Yes, makes total sense.

I was asking if you can build an example aside where we'll be able to reproduce the behavior.


Yes, i can generate an example,  but i can't generate the .ipa file for ios because the certificates and profile is generated for this app.

Thanks.

No need to generate an .ipa file, build it on your side and assure that we can replicate the behavior if we generate the same .oml on our side. Then send the example .oml and we'll try to see what's happening.

Cheers

Henrique Batista wrote:

No need to generate an .ipa file, build it on your side and assure that we can replicate the behavior if we generate the same .oml on our side. Then send the example .oml and we'll try to see what's happening.

Cheers


Hi Henrique and Kilian,


The problem appairs when i set centerlatitude and centerlongitude and later override it with logic. Now is working fine.


Thanks so much.