Enterprise Manager 2.1.1 and StyleGuide

Enterprise Manager 2.1.1 and StyleGuide

  
I've detecteted some minor issues in Enterprise Manager 2.1.1 solution, related to the use of the Style Guide.

- Some configuration tables present buttons in the last column aligned to the left (eg. CfgRoles), while others present them alignes to the right (eg. Cfg_RelationTypes).

- Screens from other omls presented in EM inside a frame present an unnecessary bottom line.

- Pagination is not working properly in some screens (eg. Cfg_Users). Page links are not shown.


Best regards,

Tiago Gafeira.
Hi Tiago.

Thanks for your feedback. Actually, three reports in one topic was certainly... unexpected!

I'll try to answer them in turns, though I'd also like to ask you if you happen to know if these problems were also present in previous Enterprise Manager versions... That would help us a lot.

>> - Some configuration tables present buttons in the last column aligned to the left (eg. CfgRoles), while others present them alignes to the right (eg. Cfg_RelationTypes).

That must've been kept that way because, during the initial conversion process of the older Enterprise Manager to the new one we tried not to change the previous layout any more than necessary... Nonetheless, if things are inconsistent, they should certainly be dealt with.

>> - Screens from other omls presented in EM inside a frame present an unnecessary bottom line.

Does this happen in all eSpaces...? If not, even a more provocative question: are those other omls originally rendered in Quirks or Standards mode? If you could provide us with a screen shot - or even better, access to a test page where we could observe that behavior, that'd be great. If you can only provide us a screen shot, we'd be glad if you inspected the screen to understand where that unnecessary bottom line is coming from (i.e. from the frame, from EM, from the other oml...).

>> - Pagination is not working properly in some screens (eg. Cfg_Users). Page links are not shown.

...definitely not good. How many records are you trying to display? In a couple of versions in the past the page links were set not to be shown if the returned results were less than the maximum record number per page... I'm not 100% sure about how it works right now, and although it is quite unlikely, could it be that your list is displaying all the records in the first page?

Thank you very much for the reports once again! Keep'em coming.

Paulo Tavares
>>>> - Pagination is not working properly in some screens (eg. Cfg_Users). Page links are not shown.

>>...definitely not good. How many records are you trying to display? In a couple of versions in the past the page links were set not to be shown if the returned results were less than the maximum record number per page... I'm not 100% sure about how it works right now, and although it is quite unlikely, could it be that your list is displaying all the records in the first page?

Of course it's not the case. :)
In the attached file you can see a screenshot of "User Accounts" screen displaying "prev" and "next" links, but not displaying page shortcuts. The installation has more than 300 users.
You can see this behaviour in any new freshly installed Enterprise Manager 2.1.1 solution.

Problem is caused by the incorrect' values assigned to "TotalRowCount" and "MaxPageNumber" os "ListNavigation" web block used in the pages.


Regards,

Tiago.
>>>> - Screens from other omls presented in EM inside a frame present an unnecessary bottom line.

>> Does this happen in all eSpaces...? If not, even a more provocative question: are those other omls originally rendered in Quirks or Standards mode? If you could provide us with a screen shot - or even better, access to a test page where we could observe that behavior, that'd be great. If you can only provide us a screen shot, we'd be glad if you inspected the screen to understand where that unnecessary bottom line is coming from (i.e. from the frame, from EM, from the other oml...).

This happens in eSpaces built using the template screenf from Template.oml shipped with Enterprise Manager 2.1.1.
The attached file show what happens for "TableRecords" screen. Tehe mentioned "extra line" is highlighted by a red elipse.

The oml is rendered in Standards mode.


Regards,

Tiago.
An example for "EditRecord" screen.