[MOBILE] Cannot see some tables in chrome

[MOBILE] Cannot see some tables in chrome

  

When i try to view my localStorage Tables in the chrome developer toolbar (F12). I miss the table localResponse, although it is filled with data. Does anyone have a clue?

I already cleared Cache rebooted, recreated the localStorage entity etc.

So what am I missing..

Hi Robert,

Have you changed the Local Entities names after running the application in the current device? If so, are you able to delete the local DB and try again?


Cheers,

Tiago.

Tiago Gafeira wrote:

Hi Robert,

Have you changed the Local Entities names after running the application in the current device? If so, are you able to delete the local DB and try again?


Cheers,

Tiago.

Thank you for answering so quickly.

What do you mean by deleting the local DB. I test and run my application inside chrome. I've used the Clear Storage function of chrome to get rid of everything and reloaded the application. This does not help.


Solution

When you change the name of an entity whose physical table has already been created, only the meta model data is changed and the actual name of the physical table remains.

Looking at your screenshot, I would bet that OSUSR_SRL_AUDIT is the physical table that hilds the LocalResponse entity data. Can you check it out?

Solution

Tiago Gafeira wrote:

When you change the name of an entity whose physical table has already been created, only the meta model data is changed and the actual name of the physical table remains.

Looking at your screenshot, I would bet that OSUSR_SRL_AUDIT is the physical table that hilds the LocalResponse entity data. Can you check it out?


Aaah yes you are right. So the Entity keeps the first name you gave it. Is there a way to refresh that?


Thank you, you helped me a lot by understanding this!

You can try Cut + Paste. A new pair Entity/Table should be created in that case.