[Microsoft Login Connector] Error page with no errors captured

[Microsoft Login Connector] Error page with no errors captured

  
Forge Component
(5)
Published on 30 Nov (3 weeks ago) by Paul Davies
5 votes
Published on 30 Nov (3 weeks ago) by Paul Davies
Getting the error below with no Error type or description. Happens after entering credentials in the demo app

Solution

I happened to have started work on implementing this myself today and had the same issue. I am assuming you followed the instructions in the Demo.

I was able to see the errors by debugging it through, but ultimately here is how I got this to work today:


Instead of creating the App Registration in the Azure Portal, I changed to creating it at https://identity.microsoft.com


  • After logging in, click on Add an App
  • Name your application, click Create
  • Generate New Password  (This will be your Client Secret).
  • Also copy the Application Id under the name
  • Click on Add Platform, and choose Web.  Set your Redirect URL to the Callback.aspx page inside the MicrosoftLoginConnector
  • Set the Delegated Permissions. What has worked for me was User.Read, User.ReadBasic.All, DIrectory.AccessAsUser.All, and Directory.Read.All
  • Add the Home Page URL
  • Click on Save.


Adjust the information as followed in the Demo App instructions with the Id and Secret as copied above.


If you left that as is, you might actually see some errors on the screen you posted. What needs to happen is the Admin Consent needs to occur, this can be done by using the following URL:


login.microsoftonline.com/common/adminconsent?client_id=XXXXXXX-XXXXX-XXXXXX&state=12345&redirect_uri=REDIRECTURIASLISTEDABOVE


If you copy that URL into a browser with the appropriate information, it will ask for Consent, then will take you back to the callback page (likely with errors), but if you try to sign back in now afterwards, it might be successful.


These steps are what worked for me.





Solution

Casey -  First issue I had was that the forge download issues today had left out some components out which I resolved.  Now having an issue with the callback where the webpage is claiming it can't find the callback page which seems to be something to do with the length of the returned values in the code parameter.  I'll follow your suggested instructions above and see if I get the same positive result you did. 

Casey - Followed your methodology still getting the same error on the callback  

/MicrosoftLoginConnector/Callback.aspx?code=AQABAAIAAADXzZ3ifr-GRbDT45zNSEFELqCjTM8XfZddL6mLvcC...………………


Will need to hit the debugger in detail I guess and work my way through what is happening.



Casey - Got it working using your identity methodology.

I'm seeing in the debugger an error when using Azure AD that the client secret doesn't authenticate.  Will have a play around to see what I can work out.