Default Value does not contain a definition

Default Value does not contain a definition

  

I've made a change to a structure (SendSMSRequest) in a module I'm consuming to give one of it's attributes (Type) a default value which I subsequently published. I refreshed the dependencies in my consuming application (using the structure) and published but it results in the following Internal Error during Compiling:

Internal Error Compilation Error. referencesProxy\eSpace_SWINT_SendInBlue_proxy.cs(70,47): error CS0117: 'ssSWINT_SendInBlue.DefaultValues' does not contain a definition for 'ReferenceStructure_SendSMSRequest_ReferenceStructureAttribute_Type' get { return ssSWINT_SendInBlue.DefaultValues.ReferenceStructure_SendSMSRequest_ReferenceStructureAttribute_Type; } State: Build References Proxy

I've tried completely removing the reference, publishing (works) and re-adding and publishing but the error persists.

I also tried toggeling the "Send Default Value" to Yes but it made no difference (see attached image).

I'm using Studio 10.0.825.0.

Any suggestions on how to resolve this?

thanks

Hi Graeme Smith.

Shouldn't that attribute be also set as mandatory?

Cheers,

GM

Hi GM

The intention was to supply this default instead so it doesn't have to be supplied by the consuming applications the majority of the time, but can be overridden only if desired. 

Graeme

Hi Graeme.

Were you able to solve this? I believe that the way your set the attribute in your first post should do exactly what you mentioned on your last one.

Cheers,

GM

Hi GM

No I rolled back the change so I could progress with other aspects of the project. 

Could this be a bug in the platform?

Graeme