iOS build generatoin failed

iOS build generatoin failed

  

Hi All, 


We are not able to generate iOS build and getting below error :


[2018-08-06T14:32:27.704Z] [ERROR]
You have been opted out of telemetry. To change this, run: cordova telemetry on.
No scripts found for hook "before_plugin_add".
Calling plugman.fetch on plugin "https://github.com/OutSystemsExperts/cordova-plugin-screen-orientation#1.4.2.os"
saving
Running command: npm install https://github.com/OutSystemsExperts/cordova-plugin-screen-orientation#1.4.2.os --production --save
Command finished with error code 0: npm install,https://github.com/OutSystemsExperts/cordova-plugin-screen-orientation#1.4.2.os,--production,--save
Error: Failed to fetch plugin https://github.com/OutSystemsExperts/cordova-plugin-screen-orientation#1.4.2.os via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
Failed to get absolute path to installed module

[2018-08-06T14:32:27.704Z] [ERROR] Build failed with the following error: Error fetching Cordova plugin: https://github.com/OutSystemsExperts/cordova-plugin-screen-orientation#1.4.2.os.
[2018-08-06T14:32:27.704Z] [INFO] Zipping application source...
[2018-08-06T14:35:09.571Z] [INFO] Application was not successfully generated!
[2018-08-06T14:35:09.571Z] [INFO] Execution time: 607569ms


Any idea what can be issue ?

Hello Akshay,


This might sound silly questions, but does your environment have access to the mentioned repository? Are you adding other plugins as well?


Seems that you're publishing onto Production environment and, for some reason, maybe a required devDependency is not being installed...


Cheers!

Armando Gomes wrote:

Hello Akshay,


This might sound silly questions, but does your environment have access to the mentioned repository? Are you adding other plugins as well?


Seems that you're publishing onto Production environment and, for some reason, maybe a required devDependency is not being installed...


Cheers!

Hey ,


Seems like environment has access to the mentioned repository because it is not giving the same error for android builds.