Issue with REST Consuming which is Exposed by me only.

Hi All,

I am facing an Issue while consuming REST web services.

I have exposed a web service in one application and consuming the same in another application in Outsystems same server. 

In Dev it is working fine but when i move code to QA  there some web services are working fine and some or giving time out issues. 

But if i check the same in QA from the postman all web service methods are working fine and getting response back.

When i try to debug in QA control is coming to web service method , And method also executing perfectly after "End" node it is not coming out from that web service method.


Then i tried consuming the web service in QA then am getting error like below.



I am using Basic authentication, Internal Access Only is "No".


Thanks

Ramakrushna Rao Seera



Hi Ramakrushna,

First a silly question: when moving the REST service eSpace from DEV to QA, did you change the base URL in Service Center? (I suppose you did, since you debugged, but have to ask anyways.)

Second question: did you check Service Center for errors? Is this caused by timeouts? Something else? (Note you can check both the Error Log and the Integration Log to check this.)

Third question: did you turn on the maximum logging level for REST APIs? Can you see whether anything was received? If so, is it in the right format?

Hey Kilian ,


Thanks for your reply.

For your first question. Yes i have changed it.  In fact it is not working with QA link , But it was working perfectly with Dev end url.

For your second question:  Yeah i have checked them , But there is no much help from service center logs.

For Third question : I haven't turned it on. 

But when i did debugging the web service method is getting executed perfectly and it is reaching "end" node  after that flow is not executing any more. 

When  i hit my service from Post Man , I am able to get proper response.



Thanks & Regards,

Ramakrushna Rao Seera

Hi Ramakrushna,

You say the logs are not much help, but if nothing's getting though I'd expect at least some error. The Integration Log should at least show the invocation, and any result.

What exactly did you debug? If you're onl debugging the REST service itself, it makes perfect sense there's nothing after the "End", as there is no flow after that. REST services are asynchronous and live in their own thread. If you are debugging both the consumer of the REST service and the REST service itself then yes, you should return to after the invocation.

I would advise you to a) check the Integration Log to see what's mentioned there for the invocation, and b) turn on the debugging to get more details.

Hi Kilian, 

Thanks for your reply..

I Found the issue , But am not sure how it is behaving like this. Here is the problem

If the size of response is huge(say for example N records) then it is giving timeout issue. So what i did for just to check I have force fully reduced the size to 1 record. Then it started working.


But the magic part is . In Dev it is working fine for the same size of response(N records) . So is there any property which holds the size of the max response pay load.?


Thanks & Regards,

Ramakrushna Rao Seera


Hello Ramakrushna,

Different context will take different time for the same action.

So, different servers may take longer to provide the same answer in a rest request.

If you're getting a timeout when trying to execute the consumed method, try to increase the Method timeout: https://success.outsystems.com/Documentation/10/Reference/Extensibility_and_Integration/REST_APIs/Consumed_REST_API/REST_API_Method

If it works, you can investigating why the same answer is faster in DEV than in QA.

Cheers

Hi Eduardo,


I have checked by increasing timeout from 100 to 1000 , Still am getting the same issue.


Thanks & Regards,

Ramakrushna Rao Seera

Please, 

Put here any entry in the monitoring relevant to the request being made, so we can take a look.
Errors, messages, etc.

Cheers.

Hi.. anyone had solved this issue? I am having the same problem.

Hi Aearon,

Exactly the same, or just similar? Can you describe what you ran into?