I have admin credentials and I am able to login in service center not in users

Is Admin credentials are different?

Because I am able to login in the service center not in users

Hi Balaji,

Go to service center > espace users and run this timer GrantAllRolesToAdmin. Your user is missing some roles.

Regards,

Marcelo

I logged with admin credentials in service center and then I ran timer that mentioned by you

But still I am not able to access

Balaji Boda wrote:

I logged with admin credentials in service center and then I ran timer that mentioned by you

But still I am not able to access

But still I am not able to access in users with admin credentials


Hi Balaji,

The timer run without problems? Are you sure you are admin? In which kind of environment are you working on? community, on premise or cloud? if it isn't community do you have access to users and roles in lifetime? if you have access which roles you have there?

Another solution starts by checking which roles has in the DB. in a espace add references to user, users_effective_role and role tables from System. Search for your user and let us know which roles you have.

Regards,

Marcelo

another question other than admin no one can able to login users?


Or

Is there any way to login into users other than admin?

Balaji, The credentials to the users module is different than the service center credentials if you never set the password to your users module it will be
User: admin
Pass: admin

The users of your platform (are people actually login in to use the software), they can also login to the users module with their credentials, but they will likely see this screen if they do not have the right level of access to manage users:

However, they can click top right 'My Info' to see their name, phone and email and change their user password. This is information linked to each user (end-user).


This is different to your IT team users (devs, devops, testers etc) and their credentials, which is managed in service center.

Hope this clarifies.


I have notified OS to make this clearer in the documentation.

Hi Balaji,

To access Users you need to have the role UserManager. Everyone with this role can access. This needs to be given with someone with the rights to do it and normally is the admin. 

There is some reason why you can't ask your admin to give you the role?

That solution I gave you is because sometimes the admin loses some roles (ex: someone removes them by mistake) and that timer gives all the roles back to the admin.

Regards,

Marcelo

André P wrote:

Balaji, The credentials to the users module is different than the service center credentials if you never set the password to your users module it will be
User: admin
Pass: admin

I have notified OS to make this clearer in the documentation.


Yes, I was also facing the same issue with enterprise account.

I was able to login with user credential on Service-Studio & Portal but not on Application.

Right now I am using the admin-admin credential, but is this a solution ?


Thanks

assif_tiger wrote:

André P wrote:

Balaji, The credentials to the users module is different than the service center credentials if you never set the password to your users module it will be
User: admin
Pass: admin

I have notified OS to make this clearer in the documentation.


Yes, I was also facing the same issue with enterprise account.

I was able to login with user credential on Service-Studio & Portal but not on Application.

Right now I am using the admin-admin credential, but is this a solution ?


Thanks

Assif,

You can change the password for admin (I would highly recommend to do so), go to top right:


Then click change password you can even have it as the same admin password as the one for service center for simplicity... but that is a choice.

Hi,

As André said you should change the password. Keep using this user is your option. Another option is to to give your own user the role UserManager.

Regards,

Marcelo

 

Hi,


I am not able to login into Users with admin or mine credentials

And also could you please tell me how should I provide UserManager role to my account

Now I have the admin role with my account and I could see in lifetime in infrastructure permissions all are on and I am under the Users tab

Still I am not able to login with my account or admin account

Balaji Boda wrote:

Now I have the admin role with my account and I could see in lifetime in infrastructure permissions all are on and I am under the Users tab

Still I am not able to login with my account or admin account

Balaji, please clarify what you mean by account and where you are trying to login.


You have a IT Admin user (the one you use to login to Service Center) - in here you can only manage IT roles, nothing related to User module.
NOTE: A USER CREATED HERE WILL NOT HAVE ACCESS TO USER MODULE

You have a User Module Admin User (the one you can use to manage roles and groups of your end users) - this is different to the IT admin User and the default credentials for this role is admin/admin, if this is not the pass then check this article: https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Resetting_the_Service_Center_admin_password

You have an End Users - that login to your app (their credentials and roles can be managed in the user module)


You can also assign roles to your own end user using logic -  


Hi Balaji,

Create a simple page and on preparation GrantUserManagerRole with this UserId = GetUserId(). This GrantUserManagerRole is on Users espace > Role > UserManager (you need to add this as reference). After creating this simple page enter this page and log in with your user.

Regards,

Marcelo




Marcelo Ferreira wrote:

Hi Balaji,

Create a simple page and on preparation GrantUserManagerRole with this UserId = GetUserId(). This GrantUserManagerRole is on Users espace > Role > UserManager (you need to add this as reference). After creating this simple page enter this page and log in with your user.

Regards,

Marcelo




Hi Marcelo, i tried your suggestion but i still can't login to the users app. I even tried calling CheckUserManagerRole and it returns true. Any thoughts?


Hi Gonza,

Can you explain your case better? Which user are you using. What kin of environment are you using (community, on premise, cloud). Which error are you getting?

Regards,

Marcelo

Hello guys.

At work, IT guys delivered to me an platform server installed missing a lot of things.

Just configured the servers, database access and nothing more.

I had to install most part os the platform installation checklist requirements. One of them, Systems Components, tha has the Users module.

After that, i tried to access the Users module and this was what i had... as seen in the picture.

What can I do?