On-Premise server cannot connect to MABS via proxy

My On-Premise server are both FrontEnd and Controller. Regarding to this documentation -


With the Network policy on my customer side, my customer only allows On-Premise server via the proxy. However, after setting the proxy on On-Premise server. We are able to connect MABS via the browser of  the On-Premise server but in the Service Center it does not. It seems like Service Center does not really connect MABS through proxy which I have configured.

Any idea on this? 

Hi Poonpipat Puriwongwanich,

How exactly did you configure your on-premise server to usa a proxy?

There are some posts on the forums around this topic, maybe one of them provides you with the needed info or hints at where to look for it.

Thanks for your Jorge. The pictures are what we configured the proxy setting on On-Premise server.

Have you tried contacting support? That will be your best option.

Hi Stacey - Yes. I am contacting with Outsystem support but there is no solution yet.


Finally, with Outsystem support team help, this is what the support team mentioned:

If it is needed to use an outgoing proxy to allow WAN access, we must choose from one of the following paths:

  1. Creating a GPO rule to define by default a proxy usage for all users.
  2. Configure the proxy on the IIS System.Web following this article, is this option we must also configure in the administration tab inside the Service Center the authentication needed to pass the proxy, is the authentication is required. 


Manually defining a proxy for the session user logged in the server will not solve the issue.

In my case, we do not use proxy authentication here is what we did: