68
Views
7
Comments
Solved
Mobile - DropdwonList do not show all items
Question

Hi,

I have a query that returns 70 records but the list only shows 23, this happens on mobile.


 I use the   DropdwonList some items appear while I used 

OnScrollEnding


But my Requirement i need all the record in DropdwonList at first time  without using OnScrollEnding


Any Help?


mvp_badge
MVP
Rank: #61
Solution

Hi Chandras,

As Tiago has said above, the 23 number is a strange one...

If you are setting 100 in Max Records you should get all 70 records...

Just another question:

  • You are using the Dropdown widget and in its List property you have the List of the Aggregate. Is that it?

As Tiago has suggested, could you share some screenshots of you implementation?

Cheers,

José

Rank: #309

Hi there,

I'm a bit lost with your description. There is no such limit for records to be shown in a Dropdown List (23 is a really unusual value for such), and OnScrollEnding should not be related to it.

Can you share some screenshots of your implementation, including the Data source and the Dropdown List binding?


Cheers,

Tiago.

mvp_badge
MVP
Rank: #61

Hi Chandras,

Just a couple of questions before I try to give you a solution to that:

  • What is the value that you are setting in the Max Records of the aggregate?
  • The query is done on Local Storage or on the Database?

Cheers,

José

mvp_badge
MVP
Rank: #61
Solution

Hi Chandras,

As Tiago has said above, the 23 number is a strange one...

If you are setting 100 in Max Records you should get all 70 records...

Just another question:

  • You are using the Dropdown widget and in its List property you have the List of the Aggregate. Is that it?

As Tiago has suggested, could you share some screenshots of you implementation?

Cheers,

José

Rank: #740

Thanks both of yoy


we setting 100 in Max Records and it's working

Rank: #1969

Hello,

I have the same kind of issue as described above. I have an aggregate which returns 40 records. When I only display the current rownumber, it displays all records, but when I insert the webblock I created, it only shows 17 records. It appears to be that my webblock is too big for the screen to load all 40 records with the webblock. I looked for max-height everywhere, but I cannot find anything to change. 

Do you know where the problem is?


Kind regards,

Tyler

Listgroupwithwebblock.png

Rank: #1969

Hi all,

I dived into this problem again with a colleague and I am happy to inform that we managed to fix the problem ourselves. 

We first tried a lot of things, but what really helped us was to Google the List Group item that we were using. We found online that many people have problems with this List Group when using a complex div structure to display for each record in this list. After searching for a while, we came across the Disable Virtualization attribute of the list group. What happens is that when the list strucure becomes too large, the records of the list are not loaded in the DOM. When setting Disable Virtualization to "True", you force the DOM to load all the elements in the list and therefore our initial problem is solved. 

Schermafbeelding20200916101823.png