HTMLTOPDFCONVERTER: Weird Line at the end of the file

HTMLTOPDFCONVERTER: Weird Line at the end of the file

  

Does anybody encounter this weird line at the end of the pdf? I am currently using DUBLIN TEMPLATE

Preview Screenshot:


This is the output pdf.




Any input/feedback on how to fix this appreciated.

Thank you

Hi Michael,

That seems like an issue with the layout you are using on your screen... can you see that line on the screen that you are passing as input to HtmlToPdfConverter?

Jorge Martins wrote:

Hi Michael,

That seems like an issue with the layout you are using on your screen... can you see that line on the screen that you are passing as input to HtmlToPdfConverter?

Yes, Depending on the size of the screen. please see below screenshot for your reference.

At 100% I cannot see any weird line.


If you increase the size to more than 100% not sure.


How did you get the background to be white? did you change the background-color of the body element?

Jorge Martins wrote:

How did you get the background to be white? did you change the background-color of the body element?

I added a background-color:#ffff; (white color) style to the Generate Page. 

Without this property the page is all color grey.



Please try opening the CSS editor (button on toolbar) and adding this:

body { background-color: white; }
.Content { background-color: white; }
.MainContent { background-color: white; }

It should be enough to make your screen white, with no need for the extended property on the screen itself.

Jorge Martins wrote:

Please try opening the CSS editor (button on toolbar) and adding this:

body { background-color: white; }
.Content { background-color: white; }
.MainContent { background-color: white; }

It should be enough to make your screen white, with no need for the extended property on the screen itself.

Jorge,

Sorry, you want me to put the CSS here?

Yes but... it looks like you already have the CSS that I wanted you to add.

I'd consider removing the Extended Property "style" from your Generate web screen, just to rule out possibly weird interactions.

Jorge Martins wrote:

Yes but... it looks like you already have the CSS that I wanted you to add.

I'd consider removing the Extended Property "style" from your Generate web screen, just to rule out possibly weird interactions.

Already added it and the weird line still exist. If I inspect element the weird line cannot be seen


Michael Chu wrote:

Jorge Martins wrote:

Yes but... it looks like you already have the CSS that I wanted you to add.

I'd consider removing the Extended Property "style" from your Generate web screen, just to rule out possibly weird interactions.

Already added it and the weird line still exist. If I inspect element the weird line cannot be seen



Has anyone encounter this issue before and recommend on how to fix this?


My suggestion (well... actually a little birdie suggested me this) is implement your screen from scratch, to try and see if it's a quirk of your current screen layout/theme.

Create a new module, use an empty theme, and gradually add the minimum CSS you need to get the PDF you want...

Jorge Martins wrote:

My suggestion (well... actually a little birdie suggested me this) is implement your screen from scratch, to try and see if it's a quirk of your current screen layout/theme.

Create a new module, use an empty theme, and gradually add the minimum CSS you need to get the PDF you want...

I will try it out and see if anything came up,.