Fail to import datarecords when bootstrapping data from Excel

Fail to import datarecords when bootstrapping data from Excel

  

Hi all,

I have tried to bootstrap an Excel Sheet into Outsystems.

Colums match with the entity attributes, as shown here:

When bootstrapped no data is shown eg below:

What could be the issue here?


Many thanks!

Hi,

Can you share the only so we can look into it?

Regards,

Marcelo

Hi Matthias, 

I suggest you take a look into this official document explanation on how to boostrap an entity using an excel file.

You might want to validate in your application:

  • Each Excel sheet must have the name of the Entity;
  • Each column header must have the name of the Entity attribute.

In case this does not work, please provide the excel file and oml (as Marcelo Ferreira said).

Regards,

Hi both,

many thanks for the feedback.

As far as I can see columns match entities. 

I have changed the name of my Excel sheet, but that didn't do the trick.

In attachment you can find both files.

Many thanks,

Regards

Attached is the Excel sheet...

Marco Arede wrote:

Hi Matthias, 

I suggest you take a look into this official document explanation on how to boostrap an entity using an excel file.

You might want to validate in your application:

  • Each Excel sheet must have the name of the Entity;
  • Each column header must have the name of the Entity attribute.

In case this does not work, please provide the excel file and oml (as Marcelo Ferreira said).

Regards,

Hi,

many thanks for the feedback.

As far as I can see columns match entities. 

I have changed the name of my Excel sheet, but that didn't do the trick.

In attachment you can find both files.

Many thanks,

Regards


Marco Arede wrote:

Hi Matthias, 

I suggest you take a look into this official document explanation on how to boostrap an entity using an excel file.

You might want to validate in your application:

  • Each Excel sheet must have the name of the Entity;
  • Each column header must have the name of the Entity attribute.

In case this does not work, please provide the excel file and oml (as Marcelo Ferreira said).

Regards,



Hi Matthias,

The code is correct and is working. Are you sure your table is empty? do you know how to debug? maybe debugging you can check what is going on on your environment.

https://success.outsystems.com/Documentation/10/Developing_an_Application/Troubleshooting_Applications/Debugging_Applications

Regards,

Marcelo

Solution

Hi Matthias,

After bootstrap an Excel Sheet into entity please publish the espace.

I think you are right clicking on entity and clicking on view data and showing no records.

Please drag the entity in any action then you will see the data like below.



Regards

-SK-

Solution