something went wrong with my API display data

something went wrong with my API display data

  

I don't make any changes to the screen but, the Id data increase from 100 to 101. can someone look whats wrong with my oml?

Solution

Hello Calvin,


There is nothing wrong with your code. 

The Rest call brings 101 elements (starting position 0, so "[100]" means 101 elements). Check the print screen below. 

So everything is fine on your side. If you want to remove that record you need to add additional logic on your side of the application.


I believe that this is just a demo application, but please take in consideration that this call on the preparation is something very heavy, and it can impact the overall performance.


Regards,

Solution

but before I made a change to DataComments screen, the data still 100, then after I republished it, it became 101. is it still fine? Looks like something wrong tho

Calvin,


I don't know what Rest Service you are calling, but it is something that on this application you are not controlling. (It is an External Data service). Since it is a call to an external service the data on that service can change anytime, and you are not the owner of that Data.


Regards

Davide Periquito wrote:

Calvin,


I don't know what Rest Service you are calling, but it is something that on this application you are not controlling. (It is an External Data service). Since it is a call to an external service the data on that service can change anytime, and you are not the owner of that Data.


Regards

thats true, thanks