In recently changed the email settings on my person space, and now all my eSpaces have the warning "This eSpace has pending configuration changes. Apply them using a solution containing all modules." and I can't seem to be able to publish them at all.

I did just this, trying to create a solution with all my modules and republish it, but that then times out before it completes.

In addition to this, I've recently upgraded my personal space to OS11, so not sure if that is contributing to the problem.

I also just tried to make a solution with the application I want to work with and all its dependencies, but that failed to publish as well.

Any help would be appreciated, and let me know if this would be more of a support issue.



Hi Jordan,

The solution should work... But it may fail for other reasons, I think.
For the application you are working, did you try to publish every module by hand?
Not the best solution, I know, but I did this very recently after changing the SMTP configuration and it worked.



Hi Jordan,

The "apply configurations" is a new behavior of OutSystems 11 that is better explained in this article: Applying Configurations in Service Center. When you change settings in Service Center, a message pops up with this link.

The email settings you changed are environment runtime configurations and don't require republishing the modules to be applied. What you need to do is have/create a solution with all components and use the "Apply Settings" button, instead of publishing the solution.

Hope this helps!


Hi Paulo,

Thanks for the heads up and the link to the documentation. :)


Ahhh, that is a much better answer. I will test it when my Personal environment starts working again...

I believe Paulo had the right answer in a normal situation.

However, I think my space was having a bit of trouble because I had not ever done a full republish after being upgraded to Platform 11.

So I ended up having to take the solution with all my application and publish it, but what finally fixed it for me was using the "publish with full compilation" check box, at which point the publish finally went through without failing.

Thanks guys.

We are running OS11 on-premise.

We changed the Date Format in the Administration > Environment Configurations section, which the article describes as a Compile-time change.  

At the eSpace level, there is an option to "Redeploy Published Version".  When selected, this cleared the warning: This eSpace module has pending configuration changes. Republish the eSpace module to apply them.

I understand that Redeploy is different than Re/Publish.  "Redeploy" copies the already compiled code in the "save" folder of the controller server to the runtime folder.  Re/Publish actually recompiles the code.

1) Is this true?

2) If so, and using Redeploy, is the Date Format change not really getting applied?  If so, it seems Service Center is only able to understand a configuration change was made and a type of activity was performed that may have cleared it but doesn't really know all the configuration elements themselves and what activity is needed to clear it.

Hey ChrisRE, I recommend posting your question as a new thread because this one is marked as "Solved" so you will get less visibility.