Development Environment 11 - Release 3 - Errors found

Development Environment 11 - Release 3 - Errors found

  

Installed the new version (11.0.113.0) but found some errors, will try to list them here ;-)

In mobile development the "In Styles Editor" is not reachable somehow, because a lot of basic things moved there now (like center and margins etc) it's really not fast developing anymore, so have to use properties and set the style there. 

There are icons at the top of the designer to set left/center/right align, they just are enabled when you select an item in the breadcrumb bar at the bottom

Crashes when doing a Ctrl+C on several items (just crashed on the greyed out "In styles editor" text, but had some other places where the same stuff happened)

I surely will not advise anyone on a production environment to make the move to 11 at this point. It works ok but with too much pitfalls at this moment which can slow down development considerably, but that's my impression :-)

I did have a lot of problems with crashes/freezes on getting or checking dependencies, that seems to be solved after completely republishing my personal environment. Also crashes on dragging entties and atrributes, but these are solved with this latest release. 

Also my personal environment is not working fine, deployment controller and scheduler seem to be down, already asked via support request for a reboot.

Funny thing is I am doing the online training for mobile developer (designed for 10 but doing it on 11), really simple and basic stuff that sometimes doesn't work.I have the feeling testing of the new environment was more focused on new stuff iso the old stuff and they missed on some bugs, pretty strange. 

Wim van den Brink wrote:

Installed the new version (11.0.113.0) but found some errors, will try to list them here ;-)

In mobile development the "In Styles Editor" is not reachable somehow, because a lot of basic things moved there now (like center and margins etc) it's really not fast developing anymore, so have to use properties and set the style there. 

There are icons at the top of the designer to set left/center/right align, they just are enabled when you select an item in the breadcrumb bar at the bottom

Crashes when doing a Ctrl+C on several items (just crashed on the greyed out "In styles editor" text, but had some other places where the same stuff happened)

I surely will not advise anyone on a production environment to make the move to 11 at this point. It works ok but with too much pitfalls at this moment which can slow down development considerably, but that's my impression :-)

I did have a lot of problems with crashes/freezes on getting or checking dependencies, that seems to be solved after completely republishing my personal environment. Also crashes on dragging entties and atrributes, but these are solved with this latest release. 

Also my personal environment is not working fine, deployment controller and scheduler seem to be down, already asked via support request for a reboot.

Funny thing is I am doing the online training for mobile developer (designed for 10 but doing it on 11), really simple and basic stuff that sometimes doesn't work.I have the feeling testing of the new environment was more focused on new stuff iso the old stuff and they missed on some bugs, pretty strange. 

We also experience several issues that you describe especially the crashes/freezes on getting or checking dependencies. One of our new hires who is doing the mobile guided path experience also problems in completing the exercises with version 11.


I found out that recompiling my complete personal environment did solve some problems with the references, it appeared that a lot of eSpaces where invalid somehow. Maybe just create a solution of everything a do a recompile maybe helps for him also. Furthermore, OutSystems support did some repairing using a commandline option for service studio thats described here, that did help to recover my bad eSpace for a while.


Regards,

Wim

Yesterday also heard from a colleague the same freezing problem when getting / checking for dependencies and he was using version 10. Like Wim described, he was also able to repair it using the same command line option.

Anyway it seems to be a problem affecting both P10 and P11.

After some testing .. the Styles editor is not reachable by double clicking on the styles, but using the tools icon on the top of the properties window .. ow bummer ;-) maybe they should drop the grey lines or make them clickable or with the to dots at the end (..) (to help idiots like me to get into the right direction ;-)).

Still have the dependencies blocking shit, but its solvable soon by using the method described here its just saving your espace, open command line and use -recover to get your espace fixed. It will open Service Studio and you fixed espace is opened and you can add refs again. 

Its not nice but its fixable, but should be fixed on a more normal base soon i hope..

Solution

They solved the hanging Service Studio with dependencies bug https://success.outsystems.com/Support/Release_Notes/11/Development_Environment/Development_Environment_Release_4

Last item in the bug list

Solution