idp example with Azure AD

Hi, I have downloaded the example (both idp connector and idp example)

I have followed the instruction to add idp Example to Azure AD with the this link '' and setup SSO (SAML).

Then I configured idp in the configuration menu of idp connector.

I didn't change anything in idp Example beside updating the references the publish it.

I have tried testing the sign-in either directly through the Example app or Azure AD test button.  Both ways gave me the same result --->  Browser keep loading and the status bar keep switching these two messages: 'Waiting for' and 'Waiting for login'

Azure AD told me it successfully issued a token (SAML response) to the application (service provider).

What am I missing here?  

I have changed the link back to

Now it gave me 'UNABLE TO PROCESS REQUEST'.  I have already checked the configuration and should have no problem.  The only thing I can think of is I am using Service Studio 11 release 3.  When I downloaded the Idp connector plugin, the only option is force install because of incompatibility.  I installed it anyway.  Then I opened idp, Service Studio asked me missing/incompatible dependencies.  I then pressed 'Refresh all' and 'OK'.  Everything seems fine.  I can compile idp and publish it to my environment.

So is there anything wrong during idp installation and updating dependency?

Hi william,

I hope you have solved the issue by now, but in case you haven't. I have had the same issue. In our case the problem was that the user was being created in outsystems and we used a value for the external id, which is stored in the users table I believe, which was too long. It can handle a maximum of 36 characters. We solved it by just selecting a different claim for the external id.