ListBox inside Table Records -"Object Reference not set to an instance of an object."

ListBox inside Table Records -"Object Reference not set to an instance of an object."

  

Hi,

So here's what I have,

When I press the "+Add Record" link it does a list insert which inserts a new line on the table with blank inputs where I can create a new record, this was working fine, until I inserted a list box in the "Intervenientes" collumn when the new line is created,

The listbox uses JS so I can select multiple options

Just like this,

Here's the properties window,

And here's the error,

So... How can I fix this?

Hello Fábio,


What´s the data type, for the "Intervenientes"´s attribute?

Thank you.

André Carvalho wrote:

Hello Fábio,


What´s the data type, for the "Intervenientes"´s attribute?

Thank you.

Hey André,

So Intervenientes isn't really an attribute,

I have a table called "FuncionariosAccao" which has "FuncionarioId" & "AccaoId" which will assign a worker to an action, the Intervenientes list box will list every single worker so I can select the ones I want, and the expression under the listbox is a webblock that collects the workers assign to that "Accao"

Hi,

I'm having a very similar problem. Did you come up with a solution to that?

Fábio Rodrigues wrote:

Hi,

So here's what I have,

When I press the "+Add Record" link it does a list insert which inserts a new line on the table with blank inputs where I can create a new record, this was working fine, until I inserted a list box in the "Intervenientes" collumn when the new line is created,

The listbox uses JS so I can select multiple options

Just like this,

Here's the properties window,

And here's the error,

So... How can I fix this?


Hi Fábio,

Did you solve this situation?

If you don't, I suggest to you to put your ListBox inside a Web Block. In this Web Block you must have a action to send a notify.

Below I show some images of what we did.






Best Regards,

Nelson