[CKEditor] How to prevent ckeditor from changing html code

Forge Component
(29)
Published on 26 May by Prasad Rao
29 votes
Published on 26 May by Prasad Rao

Hi Guys, 

Immediately after pasting our HTML on CKEditor we notice that CKeditor changed the HTML code causing some issues on the output result. ( missing paddings,  incorrect bold, etc ) 

How can we instruct ckEditor not to change the HTML code?

We already tried to use the configuration allowedContent = true but with no success, when we did this several buttons disappeared from the toolbar and more HTML tags disappeared from the code.

Has someone experienced the same behavior? how can it be solved?

Thanks in advance


Hi,


I think this is more of an issue with CKEditor itself, so better search in their forums.


Sérgio Manuel Silva wrote:

Hi Guys, 

Immediately after pasting our HTML on CKEditor we notice that CKeditor changed the HTML code causing some issues on the output result. ( missing paddings,  incorrect bold, etc ) 

How can we instruct ckEditor not to change the HTML code?

We already tried to use the configuration allowedContent = true but with no success, when we did this several buttons disappeared from the toolbar and more HTML tags disappeared from the code.

Has someone experienced the same behavior? how can it be solved?

Thanks in advance


Hi

we need to add allowedContent:true instead of allowedContent = true in config parameter. It is working for me.

Please refer below screen shot.