Why I can't encrypt the data?

Why I can't encrypt the data?

  

Hi everyone,


I am doing the register page, and i want to upload password to the database,

so when before i upload i have add encryptPassword action.

However, it doesn't work, the password still not been encrypt before it upload to the database.

Thanks 

eva wong wrote:

Hi everyone,


I am doing the register page, and i want to upload password to the database,

so when before i upload i have add encryptPassword action.

However, it doesn't work, the password still not been encrypt before it upload to the database.

Thanks 


Hi Eva,

you need to assign to the source of your action(create/updateuser) the output from Encrypt password action in your logic. 


Cheers,

Julius

Julius Delorino Jr. wrote:


Hi Julius,

Thank you! It's working, but i want to ask why i still can't login using the information i have just register? 

is the encrypt method not the same?  I can just login successfully when I use the ID 2 only, the rest of them can't? What is the problem? 

Thank you...

eva wong wrote:

Hi everyone,


I am doing the register page, and i want to upload password to the database,

so when before i upload i have add encryptPassword action.

However, it doesn't work, the password still not been encrypt before it upload to the database.

Thanks 


Hi Eva,

you need to assign to the source of your action(create/updateuser) the output from Encrypt password action in your logic. 


Cheers,

Julius



Hi Eva, 

glad the solution works for you, for the login issue, can you check the password you use

during login and compare it to the one you use on your encrypt password ? and also can you check on your user provider module.


Thanks Julius,

Thank you so so so  much, It has 3 different methods to encrypt data, and i use the different so the login system can't recognize.



Julius Delorino Jr. wrote:


Hi Eva, 

glad the solution works for you, for the login issue, can you check the password you use

during login and compare it to the one you use on your encrypt password ? and also can you check on your user provider module.





Solution

eva wong wrote:

Thanks Julius,

Thank you so so so  much, It has 3 different methods to encrypt data, and i use the different so the login system can't recognize.



Julius Delorino Jr. wrote:


Hi Eva, 

glad the solution works for you, for the login issue, can you check the password you use

during login and compare it to the one you use on your encrypt password ? and also can you check on your user provider module.



Hi Eva,

Glad i can help.


cheers,

Julius




Solution