LoginInfo Webblock does not show any info

LoginInfo Webblock does not show any info

  

Hi guys,


I have been following a tutorial on how to build a web-based application. I am stuck at Security Exercise Part 2 in which I have to create a login link on the top of the page. However, it does not show any information even though I already logged in. 

By right, it should be something like this:



However, on my screen it shows nothing:

Hi Sovanreach,

can you try publish your app. and try to login, it should display the logininfo  once the getuser() is not null.



Cheers,

Julius

Solution

Hi Sovanreach Chea,

The content inside the structure is not visible in the screen because...

Reason: The Container Style Class is set to Login_Info and the color property in the Login_Info class is set as color: #FFFFFF; which is white color due to this the content in the tree structure is not visible.

1) Widget Tree Structure

2) Module CSS Editor


Hope you understand the above explanation.


Kind Regards,

Benjith Sam

Solution

Julius Delorino Jr. wrote:

Hi Sovanreach,

can you try publish your app. and try to login, it should display the logininfo  once the getuser() is not null.



Cheers,

Julius

I have already published my web app and did log in to it. However, it won't show anything on my service studio

Benjith Sam wrote:

Hi Sovanreach Chea,

The content inside the structure is not visible in the screen because...

Reason: The Container Style Class is set to Login_Info and the color property in the Login_Info class is set as color: #FFFFFF; which is white color due to this the content in the tree structure is not visible.

1) Widget Tree Structure

2) Module CSS Editor


Hope you understand the above explanation.


Kind Regards,

Benjith Sam

Hi Benjith,

Thank you for your help. I encountered the same problem while trying to make the exercise. I believe the problem is that the exercises are made for Service Studio 10 but we are using Service Studio 11. The Widget Tree should display as Sovanreach posted in his first post above, however it displays this:

There is no Style Class available by the name 'Login_info" which makes it harder as that is actually the next step in the exercise (Security Exercise, Part 2, 2b and further). Any chance you (or anyone else) would know how to continue with the program in SS 11? Thanks in advance!