Hi all,

I'm getting the error: 

"Error ITMS-90717: "Invalid App Store Icon. The App Store Icon in the asset catalog in 'YourApp.app' can't be transparent nor contain an alpha channel."

At the moment I'm trying to send the .ipa to the apple store connect.


In the outsystem, application  I'm making sure I'm sending an icon without alpha channel


But, when view .ipa via ZIP archive, I checked that all the images are alpha channel. Can someone with iOS publishing experience explain where the error is?

Hi Rafael,

I don't think the problem lies in OutSystems, but rather to whatever app you're using for creating the image. Can you include the image that you exported (not the ones from the ZIP) here?

Kilian Hekhuis wrote:

Hi Rafael,

I don't think the problem lies in OutSystems, but rather to whatever app you're using for creating the image. Can you include the image that you exported (not the ones from the ZIP) here?

Thanks for the reply. Attached is the image that I'm using for Icon


Mmm, I can't see anything wrong with this image. You say that the images that are in the ZIP do have alpha? How did you check?

Using MacBook, 

You can check whether your image has alpha channels using Finder -> right clicking on your app icon .png files -> Get Info -> More Info -> alpha channel.

@Kilian,

Am I using the correct location for storing the image to be used as an icon? Is there a way to view the server if the stored image is correct?

RAFAEL FERREIRA wrote:

@Kilian,

Am I using the correct location for storing the image to be used as an icon? Is there a way to view the server if the stored image is correct?


Hello,

Is that issue resolved? I am facing the same issue in IOS.

Hi RAFAEL FERREIRA and Suhas Jamdade,

Many time PNG shows no alpha, but it takes some pixels as alpha.

Using MacBook,

Open your image in preview and duplicate the image. Click save as PNG and make sure you uncheck alpha channel checkbox before saving.

replace the new image in your code directory and upload it to the app store.

Hope this helps
Thanks


Viraj Kataria wrote:

Hi RAFAEL FERREIRA and Suhas Jamdade,

Many time PNG shows no alpha, but it takes some pixels as alpha.

Using MacBook,

Open your image in preview and duplicate the image. Click save as PNG and make sure you uncheck alpha channel checkbox before saving.

replace the new image in your code directory and upload it to the app store.

Hope this helps
Thanks


Ok. Thanks Viraj will try this.


Hello Viraj ,

Still not working.

Hi Suhas Jamdade,

The app store icon should be 1024*1024 with no alpha for ios.

Hope this helps!
Thanks




Viraj Kataria wrote:

Hi Suhas Jamdade,

The app store icon should be 1024*1024 with no alpha for ios.

Hope this helps!
Thanks





Its same 1024*1024.

Hi Suhas Jamdade,

Can you please share your app store icon.
And
Also, share the error msg too,

Viraj Kataria wrote:

Hi Suhas Jamdade,

Can you please share your app store icon.
And
Also, share the error msg too,

Hello Viraj,

Please find the error message and Logo.

Thanks In Adv.

Hi Suhas Jamdade,

Try the attached image as an icon

 and 

also, change your application app icon.

Hope this helps!
Thanks

Viraj Kataria wrote:

Hi Suhas Jamdade,

Try the attached image as an icon

 and 

also, change your application app icon.

Hope this helps!
Thanks


Thank you Viraj. Will check and will let you know. :)