Dear all,

i've a little issue with a input-field with connected RichWidgets\Input_Autocomplete...

When changing the text within the input-field, i would expect "OnNotify" to be called, but that's not always the case..... But i really need it to do so !

Anyone??

Thanks in advance,

Jeroen Vormer


Hi Jeroen,

You have tried put some thing in the "DelayInMiliseconds"?  The default value is 200 ms which is probably what is being used.


Regards

Graça


I've tried several things, but I just need it to go always to OnNotify.. 

The delay should not really matter i think...

Everytime i change the value within the inputfield, the autocomplete should run the OnNotify action....

That's why i also set the cacheresults to False....

This is the "DelayInMiliseconds" description: 

"The amount of milliseconds to wait for another character before showing the autocomplete list"

So I think the delay meters, if you have a delay less then 200 ms between inputing the characters it do not react until you finish writing.  

So when i put in zero, I expect it to wait for 0 seconds to show me the autocomplete list, which is after calling the OnNotify.. 

Offcourse already left it empty, but then also no OnNotify thingy.....

Can you share the oml? What is inside your OnNotify action? Are you using NotifyGetMessage() inside? 

@Roman,


I'm not using Notifygetmessage(), because it's not a real notify-thingy...

It's just a action (which is named as OnNotify) which should be called by the Autocomplete, always...., but doesn't do always....

I really need to know why.....

Jeroen Vormer wrote:

@Roman,


I'm not using Notifygetmessage(), because it's not a real notify-thingy...

It's just a action (which is named as OnNotify) which should be called by the Autocomplete, always...., but doesn't do always....

I really need to know why.....

Understood. How did you identify that it's not always called? 


I'm talking about using NotifyGetMessage() function inside your OnNotify screen action, so you can get your input and implement the populating logic. Again, oml examle of your issue would help the best. 


I'm debugging with a breakpoint at the start of the OnNotify action.

Only 1 out of six times the action is called because of the caching of the autocomplete widget. 

Trust me, there's nothing wrong with the OnNotify action itself. Only want to know how to get the Autocomplete Widget to call always the specified action. Even when it's called 'FooFoo' instead of 'OnNotify'....

Try to log NotifyGetMessage() without debugging. See if it changes anything 

Hi again, 

Have you tried the "on change" property on the field? 

It's another option.

Regards

Graça

@Roman, with the NotifyGetMessage() nothing changes.
@Graca, I've already tried the "OnChange" on the input field, but even that is not always triggered.

I found another post, which a little bit looks like the same issue:
https://www.outsystems.com/forums/discussion/43124/backspace-key-in-autocomplete-input/


What is the side effect of the OnChange not being called? The dropdown suggestions are incorrect?

The OnChange on the Autocomplete widget gets triggered when new results are needed. Even though with CacheResults at false it's very aggressive and calls a lot more than it should be necessary.

The OnChange on the associated input only gets (deterministically) triggered then a value is clicked or the text in the input matches the auto complete value exactly.


Regards,

João Rosado

The results are always correct, but i'm doing something with JavaScript in the action.
That's why i need it to be triggered always....
I'll try to find another solution.......

Solution

Solution: Created my own AutoComplete widget.......

Solution