Section Index on Outsystems Version 11

Hi all,


I'm having a hard time getting the section index widget to work in version 11. 


Life used to better in version 10 where section index works magic by simply dragging and dropping onto a webscreen with sections. However, in version 11, the section index icon on the left is just the same as beforem, but seems as though nothing happens when I tried to place it with sections. 


Please help.


Best Regards,

Connie

Solution

Hi Connie,

It's possible to give us an oml with your example to understand better the problem?

I've created a simple example with SectionIndex woring, please take a look to the attached file.


Thanks

Solution

bmarcelino wrote:

Hi Connie,

It's possible to give us an oml with your example to understand better the problem?

I've created a simple example with SectionIndex woring, please take a look to the attached file.


Thanks


Hi  Bmarcelino,

As I can see you have used section index using silk UI.

My questions are

1-can't we created section index only using Outsystemsuiweb?

2-if we use both silk UI and outsystemuiweb both at same times will it affect the performance because if we use silk it will load all the resources associated with silk UI?


Regards,

Pankaj Pant

Thanks Bmarcelino!! 

Turns out the new update works just fine now:

https://www.outsystems.com/forge/component-overview/4143/outsystems-ui-web


Thank you!

Pankaj pant wrote:

bmarcelino wrote:

Hi Connie,

It's possible to give us an oml with your example to understand better the problem?

I've created a simple example with SectionIndex woring, please take a look to the attached file.


Thanks


Hi  Bmarcelino,

As I can see you have used section index using silk UI.

My questions are

1-can't we created section index only using Outsystemsuiweb?

2-if we use both silk UI and outsystemuiweb both at same times will it affect the performance because if we use silk it will load all the resources associated with silk UI?


Regards,

Pankaj Pant

Hi Pankaj,

In my example i use the OutSystems UI Web for section index. It's have the same behaviour as Silk UI and the same user experience.

I don't advise you to use Silk UI and OutSystems UI in the same application because they use different templates and the CSS it's different but you can do it on your own.


Thanks


bmarcelino wrote:

Pankaj pant wrote:

bmarcelino wrote:

Hi Connie,

It's possible to give us an oml with your example to understand better the problem?

I've created a simple example with SectionIndex woring, please take a look to the attached file.


Thanks


Hi  Bmarcelino,

As I can see you have used section index using silk UI.

My questions are

1-can't we created section index only using Outsystemsuiweb?

2-if we use both silk UI and outsystemuiweb both at same times will it affect the performance because if we use silk it will load all the resources associated with silk UI?


Regards,

Pankaj Pant

Hi Pankaj,

In my example i use the OutSystems UI Web for section index. It's have the same behaviour as Silk UI and the same user experience.

I don't advise you to use Silk UI and OutSystems UI in the same application because they use different templates and the CSS it's different but you can do it on your own.


Thanks


Thanks for the clarification Bmarcelino.