I am working on OutSystems Service studio version 11.0 i.e. in cloud. I have successfully designed a To Do application, while trying to open the menu I am getting an error "Cannot read property 'style' of null". Thus I am unable to open the menu and use it. Any help would be deeply appreciated. 

Hi Shree,

Can you provide more details about how you are opening menu?

Using Link, JavaScript, JQuery etc...

Please also share a sample OML if possible to quickly identify your issue.

Regards,
Palak Patel

Palak Patel wrote:

Hi Shree,

Can you provide more details about how you are opening menu?

Using Link, JavaScript, JQuery etc...

Please also share a sample OML if possible to quickly identify your issue.

Regards,
Palak Patel

Hi Palak,

As mentioned above, I am trying to open the menu on Chrome after pressing the 'one click publish' button. This is the html message I am getting upon inspecting the error element

<div class="feedback-message-text">Cannot read property 'style' of null</div>

 So to answer your question I am opening the menu through the development environment link. I am attaching the OML of my To Do application.


Thanks & Regards 

Shree Nandan Das



Can you send todo core module then i can look into it



Solution

Hi Shree,

Your layout is missing the menu. Your layout should look like this 

Solution in attachment.

Regards,

Marcelo

Solution

Marcelo Ferreira wrote:

Hi Shree,

Your layout is missing the menu. Your layout should look like this 

Solution in attachment.

Regards,

Marcelo

Hi Marcelo,


Thanks for helping me find the solution to a problem that had me scratch my head for weeks.


Thanks & Regards,

Shree Nandan Das