[Input Mask Mobile] Range Slider with 2 Input Mask force update not working

So i have a range slider with 2 input mask, on ready both the input mask show the mask correctly but when i slide it. The mask on the other value is gone. I have tried force update 2 inputs at once and force update 1 input. But it doesn't work and it still removes the other mask. Is there any way to make this work ? Thanks !



Hi Billy,

It's hard to tell just by looking at the screenshots. Would you mind sharing an oml example of your issue?

Hi Roman,
Here is the oml. Thanks in advance !

Billy Gunawan wrote:

Hi Roman,
Here is the oml. Thanks in advance !

It's a bit different from what you have on a screenshot. And can't publish it since the dependencies are missing. What masks do you use? Why did you clone the slider? 


Sorry for the late reply, it seems i forgot to include the CloneOfMobilePattern oml. So here it is. I cloned the mobile pattern so in case i need to use it in the future i can just use it from there. I used the InputMaskMobile.

Hi Billy,

You were over complicating the valuesChange action. specially the js part.

Check the solution in attachment.

Regards,

Marcelo 

Marcelo Ferreira wrote:

Hi Billy,

You were over complicating the valuesChange action. specially the js part.

Check the solution in attachment.

Regards,

Marcelo 

Hi Marcelo, i tried using your function. It seems i have tried before trying to use force update 2 masks at the same time. But the other one is still not updating.


Hi Billy,

That's strange because I used my change and it was working perfectly. Did you publish my module and refresh dependicies? 

Regards,

Marcelo

Hi Marcelo,

I did publish it and refresh the dependencies but it is still the same. Can you send me your oml of the Test_Asun and CloneOfMobilePattern once more. Just in case i am missing something.

Regards,

Billy

Hi Billy,

I didn't do any changes to Test_Asun. Anyway attached the 2 modules that are running in my environment and both masks are working correctly.

Regards,

Marcelo

Hi Marcelo,

Everything is exactly the same but it is still not working and i have no idea why. I am so confused right now :/

Regards,

Billy

Hi Billy,

You have the latest version of InputMaskMobile component? How are you making the test? on the browser console you get any error?

Regards,

Marcelo

Hi Marcelo,

I have the InputMaskMobile version 1.0.4 which is the latest stable for Outsystems 11 (Forge said it is). I am using the Test_Asun module to do the test and i tried to slide both of the slider (There are 2 slider, 1 for the minimum value and 2nd for the maximum value). When i tried to slide the min slider, the max value mask is gone and vice versa. And it doesn't return any error when i debug it. 

Regards,

Billy

Hi Billy,

Can you send me a private message with the link to your page. So I can test it?

Regards,

Marcelo

Hi Billy,

Try to install the application in attachment and test it plz.

Regards,

Marcelo


Hi Marcelo,
I tried to install your application and this error occurred. Any idea why ?

Regards,
Billy

Solution

Hi Billy,

Because it was inside a zip it didn't remove the intellectual property of my environment.

You can install this one.

Regards,

Marcelo

Solution

Hi Marcelo,
It worked now, thanks !
Regards,
Billy