System User Table fetchs no record

Hi All,

I had created a User by making use of System user table action CreateUser in a module let it be Module1.

Now I'm trying to retrive the same user in module 2. But I could not extract the record and it show no records found.

But if I try to retrieve the same in Module1 it is returning me the User record.


So I tried to create action Module1 and imported the action into Module2. Even in this case the User table returns only empty list.


I checked the executed SQL in both of the aggregates in Module1 and Module2


Module1 it refers a view OSSYS_USER_T20

Module2 it refers a view OSSYS_USER_T142


Please help me.


Hi Ajithkumar,


Can you confirm that in both Modules they have the User Provider module set to "Users" in the Module extended properties?


They should have the same User Provider module.


Best regards,

João Marques

Hello,

Make sure the user provider is the same on both modules. Probably the module 2 end user provider is itself but it should be users.

To Change It, Open module 2 on service studio, click on the espace name and Change the property user provider and publish the espace.

User Provider eSpace

Indicates the module that provides end-users to this module, enabling the end-user to authenticate once, in one module, and gain access to the any unified module. 


Kind regards,

Márcio Menezes

João Marques wrote:

Hi Ajithkumar,


Can you confirm that in both Modules they have the User Provider module set to "Users" in the Module extended properties?


They should have the same User Provider module.


Best regards,

João Marques

Hai Jao,

Where can I see this properties? Might be a silly question but I could not find these property.


Ajithkumar Radhakrishnan wrote:

João Marques wrote:

Hi Ajithkumar,


Can you confirm that in both Modules they have the User Provider module set to "Users" in the Module extended properties?


They should have the same User Provider module.


Best regards,

João Marques

Hai Jao,

Where can I see this properties? Might be a silly question but I could not find these property.


Hi Ajithkumar Radhakrishnan,


You can able to see those properties in all the tabs. which is represented with your module name.

Hi All,


Thanks a lot issue is resolved. Thats a good learning