[IdP Mobile] IDP Mobile Log In problem

Forge Component
(2)
Published on 16 Apr (3 days ago) by Telmo Martins
2 votes
Published on 16 Apr (3 days ago) by Telmo Martins

I'm having some problems when use the IDP Mobile to Log in into a Mobile Application because the web version works.

I'm using azure external authentication but seems to fail ever-time on the exit URL condition


Index(evt_url, "MobileCloseInAppPoint") >= 0

 

That don't find the "MobileCloseInAppPoint" . If you have any suggestion to solve this problem tell me please. We are using Outsystems 11.

Hi João,

Can you share the app log, namely the log regarding of InAppBrowser events.

Regards

Telmo Martins wrote:

Hi João,

Can you share the app log, namely the log regarding of InAppBrowser events.

Regards

Hi Telmo ,

What logs are you talking about ? And our external authentication is with an Microsoft account.


Hi João,

Javascript console log of the mobile app.

Regards

Hello,

If this started recently with Android devices, this might be the same issue as in the parallel thread. We have resolved this issue with two actions Telmo mentioned in this post: https://www.outsystems.com/forums/discussion/43761/login-not-work-on-android/#Post158585

Root cause there was that the redirects were not triggering any of the intermediate loadstart events, just the first one.

br,

-Mikko(N)

Telmo Martins wrote:

Hi João,

Javascript console log of the mobile app.

Regards

Hi Telmo , is this what you want ?


Hi Joao,

Is that log, yes, but when the InAppBrowser starts.

But before that try this solution: https://www.outsystems.com/forums/discussion/43761/login-not-work-on-android/#Post158585

Regards