Error Installing LifeTime SDK

When trying to install LifetimeSDK using the url https://[lifetime_domain]/lifetimesdk

I got this errors:

Missing eSpaceRequired eSpace LifeTimeAudit was not found in this server.
Missing eSpaceRequired eSpace LifeTimeCore was not found in this server.
Missing eSpaceRequired eSpace LifeTimeMonitoring was not found in this server.
Missing eSpaceRequired eSpace LifeTimeSDK was not found in this server.
Missing ExtensionRequired Extension LifeTimeUtils was not found in this server.


Note: Outsystems version 10.0.828.0

Tried to reinstall but always get this errors. Where I can get this eSpaces? Should come in the package.


If I recall correctly, Lifetime ships in a Solution package (.osp) that should contain all those Espaces. You simply go to service center and upload and publish 'Lifetime.osp'.

Do you know where to get LifeTime.osp for Outsystems 10?
In this link they have only LifeTime for version 11, not compatible, besides it says it is compatible with version 10:
https://www.outsystems.com/home/Download_HomeAll.aspx?VirtualDirectoryId=118 (TAB LifeTime)


More details:

Tried @Pedro Brito sugestion, downloaded LifeTime from the link above.

Extracted exe files, getting the LifeTime.osp file.

Tried to upload it in Service Center but got error saying that the environment already has LifeTime installed.

Extracted the LifeTime.osp files.

Tried to upload LifeTimeAudit.oml in ServiceCenter, but got this error:

OutSystems.Oml.UnsupportedNewerVersion: Unsupported newer version 11.0.0.200

Repeated all the steps before for the oldest Lifetime version present, but it is sill for version 11, not compatible.


Right here. You need to dig around a bit in the Downloads Archive to find it

Thanks! It works with that version.

Great, good to know that it worked! Also don't forget to mark the answer as the solution as it lets other users know this is solved.

Pedro Brito wrote:

Great, good to know that it worked! Also don't forget to mark the answer as the solution as it lets other users know this is solved.

Not yet.

After manually publish the 5 modules described above, it showed some warnings in service center saying that module references need to be updated, and URL references for WSDLs too. But couldn't update them, as they don't appear for edition in DEV, I think because are system modules.

After ignoring this warning moved to the next step, that is export data, but it stayed all night and 0% done, like in this other issue.

Ignoring this and trying to start creating a plugin, I verify that there in no template present to create a LifetimeSDK plugin.

Then removed the LifeTimeSDK Application in service center, to try to install it again, but now in the url https://[lifetimeserver]/lifetimesdk says that the lifetimeSDK is already installed...

Maybe should publish all oml files present in LifeTime.osp, in service center?


Well yes, you MUST (not really an option here) publish the Lifetime Solution in its entirety, not just specific modules. 

In your Service Center, go to Factory >> Solutions and click on 'Upload and Publish a Solution'. Then upload the Lifetime.osp and publish everything in it, no exceptions.

Already tried that, doesn't work, gives the following error:

This environment is already managed by a LifeTime running on ''xxx.zzz.dev''. You only need a single LifeTime installation to manage your infrastructure and applications.

Note that xxx.zzz.dev domain is different from the DEV server domain where i'm publishing the LifeTime.osp.

There is a way to install only the LifeTimeSDK?

You don't have to, Lifetime is installed on that environment and therefore is accessible on all environments in your infrastructure. Just make sure it is properly installed and configured in your infrastructure and you're good to go.

Pedro Brito wrote:

You don't have to, Lifetime is installed on that environment and therefore is accessible on all environments in your infrastructure. Just make sure it is properly installed and configured in your infrastructure and you're good to go.

There is a contradiction here in your 2 latest answers, please note that xxx.zzz.dev domain is different from the DEV server domain where i'm trying to publish the LifeTime.osp.


If you are facing this many difficulties I must ask this at this point: are you following the Platform Server installation checklist and the Lifetime checklist

Because they are pretty clear on what to do and how to proceed when installing an Outsystems infrastructure from scratch.

Pedro Brito wrote:

If you are facing this many difficulties I must ask this at this point: are you following the Platform Server installation checklist and the Lifetime checklist

Because they are pretty clear on what to do and how to proceed when installing an Outsystems infrastructure from scratch.

LifeTime is working fine, LifeTimeSDK is an extra that I'm trying to install acording to  https://[lifetime_domain]/lifetimesdk

Going to contact support. Thanks.