Hello All,

We could notice this error in our Service Center. Can someone tell us what is that?

Scheduler Service: Error executing request https://127.0.0.1/ECT_Provider/_TimerHandler?wsdl for Timer MigrateFeedbackTo9. Request duration = 0 secs. [Timer failed before starting: please check if there are any errors in this module]


javax.xml.ws.WebServiceException: org.apache.cxf.service.factory.ServiceConstructionException: Failed to create service.
   at org.apache.cxf.jaxws.ServiceImpl.<init>(ServiceImpl.java:151)
   
 org.apache.cxf.service.factory.ServiceConstructionException: Failed to create service.
   at org.apache.cxf.wsdl11.WSDLServiceFactory.<init>(WSDLServiceFactory.java:100)
   at org.apache.cxf.jaxws.ServiceImpl.initializePorts(ServiceImpl.java:204)
   
 javax.wsdl.WSDLException: WSDLException: faultCode=PARSER_ERROR: Problem parsing 'https://127.0.0.1/ECT_Provider/_TimerHandler?wsdl'.: java.net.ConnectException: Connection refused (Connection refused)

Thanks in Advance..!!


Regards,

Sripriya Sekar

Hi Sripriya,

Is this a one-time error? Or is it structural? If the latter, is it just the ECT_Provider timer that has this error?

Solution

Hello Kilian,

Thanks for the heads-up..!!

Yeah.. its a one time error and could see this error for other espaces too. But after our analysis, could find that particular server got rebooted at that time which may cause the timer failed state.


Regards,

Sripriya Sekar

 

Solution

Hi Sripriya,

That's indeed very likely the cause of the error. Thanks for reporting back.

Sripriya Sekar wrote:

Hello Kilian,

Thanks for the heads-up..!!

Yeah.. its a one time error and could see this error for other espaces too. But after our analysis, could find that particular server got rebooted at that time which may cause the timer failed state.


Regards,

Sripriya Sekar

Hi Sripriya

I'm having the same issue now, also caused by a server restart during the e-space publish.

What did you do to solve this? Restarted the server again?

Thank you. 


Hi Pedro,

Yeah, this error occurred due to the server restart at that time. Did you try restarting the services? 

Regards,

Sripriya Sekar

Sripriya Sekar wrote:

Hi Pedro,

Yeah, this error occurred due to the server restart at that time. Did you try restarting the services? 

Regards,

Sripriya Sekar

Hi Sripriya

It wasn´t necessary to restart the server. Throught Service Center I pressed the Redeploy Published Version on

 the e-Space page and the service was ON again. It's strange but it worked.

Thx once again!

Hi Pedro,

Great..!! Thanks for the heads-up..!!

Regards,

Sripriya Sekar