Everytime I publish , the warning below ,how can I solved?


Everytime I publish , the warning below ,how can I solved?



Solution

Hi Jack,


You should go to your service center, open rich widget and users espace, and publish the latest one 

Make sure the check is on the latest version, if not then choose publish on the latest version.

Solution

Hi Jack,

Can you tell me if you are using a cloud Environment or an on-premises one?

Those messages mean there was an incomplete upgrade to the platform server (the version of the Platform Server does not match the version of the System Components - which include RichWidgets, Users, and a lot of other useful modules). If this is happening in an on-premises environment, please contact your Sys. Admin. to complete the upgrade of the Platform Server, if this is on a cloud environment managed by OutSystems, you should contact OutSystems Support.

this is on-premises one , how can I do ? I am the sys admin. 

Jack,

You need to follow the OutSystems Installation Checklist (I linked to the version for OutSystems 11, you can also find the one that matches exactly your version inside your OutSystems Start menu folder, under Documentation if I'm not mistaken):

  • open it;
  • configure it properly (fill out the drop-downs with the right settings for your environment) and;
  • follow all the step by step instructions there (you may skip the ones marked optional)
    • namely follow the one that tells you to (re-)install (via Service Center) the System Components solution that you can find on the Platform Server folder (file is called System_Components.osp).