Unable to install old version of a component

Can I import a module made for Outsystems 8 in Outsystems 10? I thought I did this previously (almost sure) but I'm currently unable to. Any suggestions? When I want to select the file in the Environment - Open Files... dialog box the needed file format isn't available (OSP). 

Module in question: https://www.outsystems.com/forge/component-versions/540

Reason for this is that I want to update this component to OS10 and then publish it (I'm part of the team). 

OSP are solution files. You can upload .OSP files in Service Center -> Factory -> Solutions

It will import and update all the espaces/extensions you need.