FactoryConfiguration Service Center Credentials

Dear Outsystems developers,

I downloaded FactoryConfiguration from forge to change the session timeout however couldn't log in to service center. I cant log in to the service center using the credentials that i normally use to log in into the OutSystem envrionment. May I just ask which credentials will allow me to log in to the service center? 

Thanks in advance.

Hi Jermysen,

Service Center credentials are managed through LifeTime. If you are working for a company, whoever manages LifeTime can give you access (though if you don't have access currently, perhaps you're not meant to have it).

If you are on a PE, you can manage it yourself, but in that case, your username/password you use for login on the Forum, should also work for your PE (both Service Center and LifeTime).

Kilian Hekhuis wrote:

Hi Jermysen,

Service Center credentials are managed through LifeTime. If you are working for a company, whoever manages LifeTime can give you access (though if you don't have access currently, perhaps you're not meant to have it).

If you are on a PE, you can manage it yourself, but in that case, your username/password you use for login on the Forum, should also work for your PE (both Service Center and LifeTime).

Hi,

First of all thanks for the reply. It seems strange that I still cannot seem to log in despite having administrator permission. Perhaps there is a prerequisite that isn't mentioned on the FactoryConfiguration that i need to know?

Or is it possible to change the session through machine.config as mentioned in the OutSystem documentation? If so where can I find the machine.config file?

Thanks in advance 


Hi Jermysen Vendarwan,

You should probably post this in the component's Support section, you'll be more likely to get the right feedback from the right people.

There is a warning at the end of the description page, that may be relevant depending on where you are trying to use the component:

Warning: This component is not supported in Personal or Trial environments. Personal and Trial are offered on shared infrastructure where advanced configurations may affect other users and are therefore not supported.

What is the feedback message you are getting? "Invalid username or pasword" or "User must be an Administrator"? If it's the second one, then your user needs to have Full Control access to the environment set in LifeTime (typically the Administrator role will grant that):