Hi,


I am using an Animated Label. For the input box, I have an autocomplete.

Refer to the following Screenshot:

As seen above, Client Name input box has autocomplete while Client Code does not. I want to remove the placeholder "Type or Double-Click for List" that is getting set by default while using Rich-Widget Auto Complete. But, I am not able to figure out how to do the same.

Please help.


Best Regards,

Rushabh Shah

Hi Rushabn,

Use the properties of the input field that is linked with the autocomplete. Use the 'Prompt' option;



You can type "" which will over write the standard text.

Rushabh Shah wrote:

Hi,


I am using an Animated Label. For the input box, I have an autocomplete.

Refer to the following Screenshot:

As seen above, Client Name input box has autocomplete while Client Code does not. I want to remove the placeholder "Type or Double-Click for List" that is getting set by default while using Rich-Widget Auto Complete. But, I am not able to figure out how to do the same.

Please help.


Best Regards,

Rushabh Shah

You need to edit the richWidget: 

After that, you need to marge the dependencies and select the Clone or the name of your espace.


Best Regards

Martijn de Pijper wrote:

Hi Rushabn,

Use the properties of the input field that is linked with the autocomplete. Use the 'Prompt' option;



You can type "" which will over write the standard text.

Hi Martijn,

This Does not work.


Best Regards,

Rushabh Shah


Rushabh Shah wrote:

Martijn de Pijper wrote:

Hi Rushabn,

Use the properties of the input field that is linked with the autocomplete. Use the 'Prompt' option;



You can type "" which will over write the standard text.

Hi Martijn,

This Does not work.


Best Regards,

Rushabh Shah


You need to take my option 


Solution

Pedro Vila Nova wrote:

Rushabh Shah wrote:

Hi,


I am using an Animated Label. For the input box, I have an autocomplete.

Refer to the following Screenshot:

As seen above, Client Name input box has autocomplete while Client Code does not. I want to remove the placeholder "Type or Double-Click for List" that is getting set by default while using Rich-Widget Auto Complete. But, I am not able to figure out how to do the same.

Please help.


Best Regards,

Rushabh Shah

You need to edit the richWidget: 

After that, you need to marge the dependencies and select the Clone or the name of your espace.


Best Regards

Hi Pedro,


I found a work-around just now.

In the Preperation of Screen, I added the following JavaScript-Code,

SyntaxEditor Code Snippet

"OsInputPrompt_Bootstrap('"+ClientNameInputBox.Id+"', '');"

And this solves the problem rather than cloning. I found this by going through the script too. Thank You.


Best Regards,

Rushabh Shah

Solution

Hi Rushabh Shah,


Can you show your preparation ? pls


i never thought that option.

Hi Pedro,


Preperation ScreenShot:

Script ScreenShot:

Execution ScreenShots:

1. 

2.

Best Regards,

Rushabh Shah

Nice  nice workaround =)


Another question : What you have in DisableComboBoxPlaceHolder ?  
                              ComboBox have any placeholder?


Best Regards

Pedro Vila Nova

Hi Pedro,


Refer to following ScreenShots:

As seen above, I have disabled the Placeholder so that the user cannot click it as any one of the options of the list has been selected by the user.

Refer the following Screen Shot:

With the Script Code, Once User will select Rural or Urban (Rather fist hover on the options), Please Select will be disabled, and user will not be able to click on it.

Best Regards,

Rushabh Shah

Rushabh Shah,


Nice =)


Thanks for sharing 


Best Regards,

Pedro Vila Nova