[Html2PdfConverter] Need to update component with latest version of FileSystem

Forge Component
(60)
Published on 17 May by Guilherme Pereira
60 votes
Published on 17 May by Guilherme Pereira

Hello Team,

I'm using this component with latest version of FileSystem plugin (3.0.0) but while I'm trying to generate the pdf or image, following reuntime-error is coming "The system cannot find the file specified".

I Think the component needs to be updated with latest version of FileSystems.


Hi Kiran,

I can confirm that the latest Html2PdfConverter component does work with the latest FileSystem component (I just generated a PDF in an environment with that same setup).

Have you configured the component with the binaries for wkhtmltopdf? You need to go to the Administration page of the component and provide the relevant binaries (you can download them from the wkhtmltopdf website).


Jorge Martins wrote:

Hi Kiran,

I can confirm that the latest Html2PdfConverter component does work with the latest FileSystem component (I just generated a PDF in an environment with that same setup).

Have you configured the component with the binaries for wkhtmltopdf? You need to go to the Administration page of the component and provide the relevant binaries (you can download them from the wkhtmltopdf website).

Hi Jorge Martins ,

Sorry for late reply.

But i have already tried with following configurations: 

And

But its showing same error as:


Hi Kiran,


What stack, version and type of OutSystems infrastructure do you have?


Additionally what do your error logs show? Have you tried to enable the debug logs? Can you share here what those are.


Cheers,

Guilherme

Guilherme Pereira wrote:

Hi Kiran,


What stack, version and type of OutSystems infrastructure do you have?


Additionally what do your error logs show? Have you tried to enable the debug logs? Can you share here what those are.


Cheers,

Guilherme


I have Outsystems 11(latest version) and here is the error details:

Solution

Hi,


From the filepath: C:\OutSystemsSandboxes\xxxx it seems you're using the Personal Environment. Is this correct?


If so you need to enable writing on the running dir by setting the checkbox to true as instructed on the Administration page:


You should also use the MinGW based version


Cheers,

Guilherme

Solution

Thanks Guilherme Pereira,

Its working by setting the checkbox to true.

Is this configuration is only for personal environment.

Hi Kiran,


Glad you have it working.


The configuration is not exclusive for the personal environments but in those is the only way to have it working. On enterprise cloud it must be set to false and the proper path defined.


Cheers,

Guilherme