[Simple Reports] TableRecord Looping - Printed in all pages

Forge Component
(25)
Published on 2017-01-16 by Rafael Fantato
25 votes
Published on 2017-01-16 by Rafael Fantato

A loop is occurring in the browser until its crash!
I think the sequence of components seems correct. See the prints. What could be wrong?
Actually this tablerecords goes beyond a page, but should split between the pages, and not repeat itself.

Greetings,

Maurilio


Hi, Maurilio.

What you did? Just clone the web screen and then it is not working?

If the page is loading in loop could be some other JS that is breaking the JS of this component to run properly.

Or the table is empty? Could you debug to see that points?

Regards


You may have a row in your TableRecords that is taller than the height of the page. When this happens, new pages will be created in an endless loop. 

Hello everyone, thanks for the quick answers!

@Rafael, the error that appears on the console is this:

"Runtime.lastError not verified: The message port was closed before a response was received."

And the table is not empty.


@Marcos

I tried to limit the height via css and cell height, none worked.

I've limited the content of the fields as well, but it looks like the number of lines is bothering.

I tried to insert another page, for testing, just with the table, the loop does not occur, but the table is printed once only continuously, going beyond the edge of the page, ie not dividing by the content area.


Greetings,


Maurilio

Hi...


Any help or other suggestions?

I would debug in Chrome to see why rows are printing beyond the end of the page. But you can't set a breakpoint because the report is not loaded yet and once it is loaded all the code has executed so there's nothing to debug. You can solve this using Chrome Dev Tools. If you go to the Sources tab of Chrome Developer tools, you can set a breakpoint using the panel on the right. You need a breakpoint on DOM Mutation > DOMContentLoaded. Once execution is paused, you can find PrintPages.js using the panel on the left and set a breakpoint on the first line. Once you've set that breakpoint you can remove the DOMContentLoaded breakpoint and step through to see where the problem is.

It's looking like the problem might not be the height of your data but just in case, I would check: How many records are you printing? What is the height of your header row? What is the height of your tallest line? What is the height of your page?

Solution

Thanks for the tips and help.

However, I tried and in an attempt to understand what was happening, I evaluated the script and realized that it "recognizes" the lists through the Style Class Name: TableRecords and ListRecords.

So, as WARNING / OBLIGATORY, you can not "change" the TableRecords and / or ListRecords style Class Names.

Regards

Solution