Hi Guys.
Im on the tutorial for ToDo at step 6.2x and i cant seem to find 

1) CreateToDoWrapper

2)UpdateToDoWrapper

After setting ToDoCore's ToDo entity to Expose Read Only:Yes

Is there anyway i can fix this?

In your oml I dont see any wrapper in the core. I hope I got the correct oml.

Please recheck the core and republish and click on the refresh icon on whole module.


Hi.
After setting ToDoCore's ToDo entity to Expose Read Only:"Yes" you need to refresh the OML ToDo. In the space attached you don't have the ToDo entity with the property a yes.

For that:

1. Change the parameter in the espace ToDoCore's to yes.

2. Deploy the espace ToDoCore's.

3. Refresh all references in espace ToDo.

4. Have fun!

AF wrote:


Hi.
After setting ToDoCore's ToDo entity to Expose Read Only:"Yes" you need to refresh the OML ToDo. In the space attached you don't have the ToDo entity with the property a yes.

For that:

1. Change the parameter in the espace ToDoCore's to yes.

2. Deploy the espace ToDoCore's.

3. Refresh all references in espace ToDo.

4. Have fun!

I've done that to ToDo_Core 's ToDo Entity to Expose read only: Yes previously already. 

Refresh as in Publish(F5)? I've done that too. 

Now the issue is i have missing CreateToDoWrapper and UpdateToDoWrapper in the dependency even though it is reflected in the ToDo Logic section. (as shown below)

This is supposed to be how it is in the tutorial (shown below)


Solution

I found my error.

I added the server actions to ToDo instead of ToDo_Core

My bad! 

Solution