Hi all,

i'm using Service Studio 11, and if i give "full-height-vh" style class to my container, suddenly i cant scroll  the editor. And i realize, if scroll bar show up in the editor, suddenly i can't scroll the editor.

Why is this happening? thanks

Hi coba,

I already had this problem, you need to put this block down.

In my case solved the problem... I have no idea why this happens, maybe it is a bug of the service studio.


regards

Hi paulo, thanks for answering my question.
But if we have a lot of widget/content on the screen, we still cant scroll the editor even though we have put that block down.


hey 

just use  -servicestudio-overflow: visible;
in the container that generates the scroll 

Basically use the  -servicestudio tag to override styles for servicestudio render

Br 

This might be unrelated, but I faced a similar problem recently when designing a screen for a reactive web app. I copy-pasted an auto-generated login screen that came with code already, in order to create a registration screen, and this screen had this scroll down problem. I had to go the 'Interface' tab, select the respective screen, and in the 'Style Sheet' field (under 'Advanced'), clear the html code that was auto-inserted there. That allowed me to scroll down again in the App designer.

Pretty annoying feature with an unintuitive solution process.

coba aja wrote:

Hi all,

i'm using Service Studio 11, and if i give "full-height-vh" style class to my container, suddenly i cant scroll  the editor. And i realize, if scroll bar show up in the editor, suddenly i can't scroll the editor.

Why is this happening? thanks

Could you please try reset service studio preferences "Restore To Default"


coba aja wrote:

Hi all,

i'm using Service Studio 11, and if i give "full-height-vh" style class to my container, suddenly i cant scroll  the editor. And i realize, if scroll bar show up in the editor, suddenly i can't scroll the editor.

Why is this happening? thanks


Are you using Css for main-content.please check once


Regards

Rahul sahu

coba aja wrote:

Hi all,

i'm using Service Studio 11, and if i give "full-height-vh" style class to my container, suddenly i cant scroll  the editor. And i realize, if scroll bar show up in the editor, suddenly i can't scroll the editor.

Why is this happening? thanks

Hi Coba,

you can do one thing as you said you have defined height as vh .

in this case use 

-servicestudio-height: 1000px; with your class where you have defined your vh height.


Hope this solve your problem.

Best Regards,

Pankaj Pant 


Hi,

please try it, you should set a max width and/or max heigth of the container with css. Additionally, you should use the CSS overflow property to make the container scrollable.

example:

.ScrollableContainer {
   max-width: 300px;
   max-height: 300px;
   overflow: auto;
}


More info on overflow:
https://www.w3schools.com/cssref/pr_pos_overflow.asp


Cheers,
Miguel