[Camera Plugin] Plugin not working with outsystems 10

Forge Component
(15)
Published on 2018-11-13 by OutSystems R&D
15 votes
Published on 2018-11-13 by OutSystems R&D

 I can't even generate a new version of my aplication because this error. My aplication is already in production, i need to solve this problem fast.

Hello, Ruben,

Judging by the error, it doesn't look related to the Camera plugin, but instead "Background Mode". Having said that, it looks as though the plugin is not compatible with MABS, which uses Java 6, since its source code uses lambda expressions, only available on Java 7. Indeed, there are even recent reports of this on the plugin's repository.

How you didn't bump into the error on previous environments, however, I'm not sure, but I'm pretty convinced it's not related to a recent change to MABS. Are you using a tag to use the same version of the plugin consistently, as documented as a best practice? If not, the most recent version made available will be fetched once the app is generated, which may not be compatible.

Since you are hard pressed to get your app generated again, I'd suggest adding a tag to the Git URL on the Extensibility Configurations of your plugin (maybe "v0.7.2", which is the latest on the plugin's repository?). If you don't have a module with this plugin, it's also possible that it may be referenced via "plugin.xml".

First things first: can you please check if my explanation adds up and if ultimately you were able to overcome the issue?

Best regards,

Carlos Simões