Table records validations are not working

Hello,

I have a table record like this to insert the values.


Before saving into the database, I'm checking if value is zero, then throw exception.

Though I enter value, it is still throwing an exception. Basically, mt table record is having 0 values while I submit.

Please advice how to overcome.

Note: I tried to change link type of screen action as Submit as well as Ajax Submit.


Thanks and Regards,

Suraj Borade

Hi Suraj,

You need to check that on the textbox's you are using the table record instead of the list that feeds it and the same for the check that you do on the save. If its not this can you replicate the behavior in test module and share with us plz.

Regards,

Marcelo

Suraj Borade wrote:

Hello,

I have a table record like this to insert the values.


Before saving into the database, I'm checking if value is zero, then throw exception.

Though I enter value, it is still throwing an exception. Basically, mt table record is having 0 values while I submit.

Please advice how to overcome.

Note: I tried to change link type of screen action as Submit as well as Ajax Submit.


Thanks and Regards,

Suraj Borade

Hello Suraj, 

can I ask you how are you doing that validation? Are you using the correct variable when validating the if there are null values? 

Best Regards


Hi Suraj,


Might be you are not checking the correct variable which is holding the input value in your condition.Could you please check your input field variable and variable in validation condition.

Also If possible try to debug the action It will give you correct picture. 

Thanks,

Manish Pandey 

Hello guys,

Thanks for the replies.

As of now I have removed the validations and found one strange thing.

In attached module, I have screen 'New Agreement'.

There I have an action 'SaveAsDraft'.

There I'm trying to save the values from the table records.

I noticed that values for some rows are getting saved and values for some rows are not getting saved.

Please advice.


Thanks and Regards,

Suraj Borade

Manish Pandey wrote:

Hi Suraj,


Might be you are not checking the correct variable which is holding the input value in your condition.Could you please check your input field variable and variable in validation condition.

Also If possible try to debug the action It will give you correct picture. 

Thanks,

Manish Pandey 


Hi Manish,

Thanks. I'have checked everything. Values for some rows are coming and values for some rows are coming empty.