Removing old espaces versions that are tagged


I want to clean up my database by deleting older versions of my espaces. But currently I cannot do that because there's an message that says "xxx eSpace versions are excluded from this list because they are used in tagged versions of applications or solutions"

I know someone has already asked this questions in here:

and yet there's no satisfying answer there. I want to know how do I delete old version of my espaces that are tagged? I've checked my lifetime but I don't really know how to untagged them because the version that it shown in there is earlier version (ver 0.1).

For additional information, I am using personal environment in this case.

Thank you and kind regards,


Have you tried this component:


If so, and that doesn't work, you may need to open a support ticket.


I think Tag versions cannot be deleted, BUT ...with the Febr 2019 update of LifeTime I believe it will be possible.

  • It is now possible to delete application versions (LifeTime tags) using the new method "DELETE /applications/{ApplicationKey}/versions/{VersionKey}/" of LifeTime Deployment API v2. This feature will allow to delete in the environments the old module versions previously tagged by LifeTime. It requires Platform Server 10.0.912.0 (OutSystems 10 environments) or Platform Server 11 - Release Sep.2018 Cumulative Patch 1 (OutSystems 11 environments). Inspired by Harlin Setiadarma's idea. (RLIT-2399)

Hello Daniel,

Thank you so much for your information. Referring to the article that you give me, does that mean that they only allow us to delete the old version one by one?



Hello Andrew,

I've tried the "db cleaner on steroids", it could delete some of the old versions but not all of it. I've tried to delete it all twice already and yet more than 300mb of old versions of my espace are still there. There is no error message or anything at all in service studio that explain to me why I couldn't delete all of my old versions. What do you think is the problem here? Thank you so much.



Same here, really hoping there can be an answer :) 

I recognize this thread is 2 years old - BUT - I am on OS v11 in my personal env and having the exact same problem. Service Center, DB Cleaner, DB Cleaner on Steroids ... none of them will delete all of the old versions of modules. I even tried tagging the current version of the Application then tried to delete the old Application still nothing.

It tells me the old version is still tagged - but - how do I untag so then I can delete?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.