HTML2PDF - Could not find file 'C:\Windows\TEMP\TEMPPJNAXIDTGA00000000000000000000000

Hi all,


I'm trying to implement HTML2PDF in Outsystems platform 11 (Enterprise on-premises version) and I have this error:


I already try with different binary versions that all posts about this topic mentioned (MinGW, msvc,...) and I have always this error.

I already try to edit the path c:\Windows\TEMP\ to other and the error it's the same, but with different path.

I already try with "Write binaries to running dir" as true and false. The error is the same.

My current configuration is this:


Someone can help about this? What can I do to get the correct behavior? I'm using HTML2PDF version 1.1.16.


Thank you all for your attention.


Best regards,

Ricardo Pereira


Hi Ricardo,

Binaries that you extracted should have a small name. Because the Input field provided is having character limitations. I had gone through the same condition. Please check if it is the same happening with you.




Hope this will help you,

Regards,

Amreen

Hi Amreen,


I don't know if I understand you, but my problem it's not when I upload binary files. My problem it's when I try do convert a web page to pdf. I already saw in HTML2PDF database and the binaries are all there.


Can you be more specific about your solution please?

Thanks!


Best regards,

Ricardo 

Ricardo Pereira wrote:

Hi Amreen,


I don't know if I understand you, but my problem it's not when I upload binary files. My problem it's when I try do convert a web page to pdf. I already saw in HTML2PDF database and the binaries are all there.


Can you be more specific about your solution please?

Thanks!


Best regards,

Ricardo 


This is my demo app. Hope this will help you what I am trying to tell you.

Amreen, thank's for your help.


I'm sorry but after compiling I have the same error. In your demo, where did I need to look at? I saw everything and everything is similar to what I have.


Best regards,


Ricardo

Ricardo Pereira wrote:

Amreen, thank's for your help.


I'm sorry but after compiling I have the same error. In your demo, where did I need to look at? I saw everything and everything is similar to what I have.


Best regards,


Ricardo


Where did you extract your binaries? Can please tell me the length of characters of a file name?

Hi Ricardo,


Does the application have write access to the directory d:/user and access to the website you're trying to generate?


Regards
Diogo Gomes

Amreen,


I download it from here: https://wkhtmltopdf.org/downloads.html

I already tried all versions, even the bleading edge.


The length that you refer is for the binary files? They have small size:

I don't refer that the error appears in my app and in the pdf generator from HTM2PDF app.

Thank you for your help.


Best regards,

Ricardo


Hi Diogo,


Yes and yes. :) In the HTML2PDF app I'm trying to convert to pdf google's page. In my app The webpage that I'm trying to convert is set to "Anonymous".


Thank's!

Best regards,

Ricardo

Ricardo Pereira wrote:

Amreen,


I download it from here: https://wkhtmltopdf.org/downloads.html

I already tried all versions, even the bleading edge.


The length that you refer is for the binary files? They have small size:

I don't refer that the error appears in my app and in the pdf generator from HTM2PDF app.

Thank you for your help.


Best regards,

Ricardo



please refer this thread

https://www.outsystems.com/forums/discussion/39579/htmltopdf-could-not-find-the-file/

I think there are permission issues with the path.

Ricardo Pereira wrote:

Hi Diogo,


Yes and yes. :) In the HTML2PDF app I'm trying to convert to pdf google's page. In my app The webpage that I'm trying to convert is set to "Anonymous".


Thank's!

Best regards,

Ricardo

Last time I got this issues was network related issues. Have you tried creating a new folder e.g."C:\tempPDF" and make the pdf's being generated there? Do you have access also to "c:\Windows\temp"


Hi all,

Thank you all by your help!

I already change the working directory and path to a directory where IIS user have permissions and the error still the same. I already tried with other binaries versions and the result is the same.


Any suggestions? 


Thanks!


Best regards,

Ricardo

Ricardo Pereira wrote:

Hi all,

Thank you all by your help!

I already change the working directory and path to a directory where IIS user have permissions and the error still the same. I already tried with other binaries versions and the result is the same.


Any suggestions? 


Thanks!


Best regards,

Ricardo

I really thought it was the permissions, did you check access to the windows temp directory can you create a file in there? You can also try to tick the option to write the binaries on the running dir.


Regards,

Diogo Gomes


I Diogo,

Thanks for your time and suggestions.


I did what you wrote (tick the option to write the binaries on the running dir) and the error disappeared. 

With that, other problem appeared. Now, The generated pdf is a blank page (in the html2pdf web app and in my app).


Someone knows why this appends?


Best regards,

Ricardo


Ricardo,

Just want to check if this is the one you are using HTMLConvertToPDF.xif in your espace?

Hi Michael,


Yes, it is!

Thanks!


Best regards,

Ricardo