Email content is not visible

Hi everyone!


When I send an email, first what I see is link with text "See full content". When I click that link it redirects another page, where I can see sended Email.


How can I solve this problem. I mean instead of "See full content" link I see full content.


Hi Stepan,

Can you elaborate it more , where are you looking at the links and what is your use case for this.



Regards,

-PJ-

PRAMOD JAIN wrote:

Hi Stepan,

Can you elaborate it more , where are you looking at the links and what is your use case for this.



Regards,

-PJ-


Every time, when I send an email, instead of real email content I see that link. I will see needed email content just when I click that link.

Is this in context with Outsystems development where you are sending email out from Outsystems and want to see the contents of the email being sent?

I am assuming you have a page on which you may be showing the title of the email and the link to load the contents of email on click.

Regards,

-PJ-


PRAMOD JAIN wrote:

Is this in context with Outsystems development where you are sending email out from Outsystems and want to see the contents of the email being sent?

I am assuming you have a page on which you may be showing the title of the email and the link to load the contents of email on click.

Regards,

-PJ-


I don't need that link. I need show just email context which I send.


Hi Stepan,

That is a Gmail behaviour, when emails are too large (HTML > 102KB according to this source) it defaults to only showing them partially and allowing you to view the full version in a popup.

The way around this is to make your email smaller. Start by making sure you are using an Email theme for the UI Flow where you defined your Email, and that you are using the Email layout (or similar) for your email, and minimize the use of inline images and complex CSS (all CSS will be inlined for emails, and this can quickly build up to a size that Gmail truncates like you are observing).

Jorge Martins wrote:

Hi Stepan,

That is a Gmail behaviour, when emails are too large (HTML > 102KB according to this source) it defaults to only showing them partially and allowing you to view the full version in a popup.

The way around this is to make your email smaller. Start by making sure you are using an Email theme for the UI Flow where you defined your Email, and that you are using the Email layout (or similar) for your email, and minimize the use of inline images and complex CSS (all CSS will be inlined for emails, and this can quickly build up to a size that Gmail truncates like you are observing).


Thank You Gorge Martins.


You are right, but even if my email context I have just one character, I see same link... Is there any way to minimize email?

Solution

Stepan,

The answer is above, make sure you create your email in a UI Flow with its Theme set to Email (defined in the OutSystemsUIWeb module) - the first Web Responsive module in an application created in OutSystems 11 will have an Email UI Flow with this setting. This theme was especially designed to be minimal, no unnecessary CSS.

Solution