[SOAP Extensibility Samples] Build Tools?

Forge Component
(4)
Published on 15 Feb by Pedro Guimarães
4 votes
Published on 15 Feb by Pedro Guimarães

Running into an error publishing the plugin on OutSystems 11.  Says it needs to recompile.  What version of the build tools do I need to have installed?

HI Kevin,

Please see this Link


Regards,

-PJ-

Hi PJ,

I have MSVS Build Tools 2017 and .NET 4.7.1 installed. According to that doc this should meet the requirements.  

This is the error message I receive when compiling.

C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets(1179,5): error MSB3644: The reference assemblies for framework ".NETFramework,Version=v4.6.1" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend.