Unable to view my Front end server in ServiceCenter

Hi All,

Recently we have upgraded the latest version of OutSystems in our environment. After that patching, we have refreshed the Outsystems services. 

After refreshing, the log service is not coming up and front end server is not displaying in the Service Center, getting the below error

2019-03-27 08:10:27,624 ERROR [outsystems.hubedition.util.ServerLog - Thread-8] Initialization error: java.lang.IllegalStateException: Invalid Connection String : Unable to register the Front-end Server. The server's connection string is different from the Deployment Controller's connection string.
   at outsystems.hubedition.deployservice.Deploy.subscribe(Unknown Source)
   at outsystems.hubedition.deployservice.Service.reallyStart(Unknown Source)


Kindly do the needful ASAP. Thanks in Advance..!!


Regards,

Sripriya Sekar 


Solution

Hi Sripriya,

I think there is a configuration mismatch on your front end server.

1. Remote login your deployment controller server and open OutSystems configuration tool.
2. Export your deployment controller configuration and copy to your front end server.
3. On your front end server open OutSystems configuration tool and import configuration which you exported from deployment controller server. (step 2)
4. Test connections
5. Appy and Exit (If step 4 success)

Hope it helps.

Solution

Hi Ferhat,

Yeah. I have tried this. Now, able to view my front-end in Service Center and the services weren't running for this server. Any idea why its not coming up?

Thanks in Advance..!!

Regards,

Sripriya Sekar


Hi Sriptiya,

I think we can't say a certain reason why services weren't running.
You need to review windows event logs.

Hi Ferhat,

Thanks for your help on this. Currently we are working with OutSystems Product team to resolve this issue.

Regards,

Sripriya Sekar