[Firebase Cloud Message Plugin] Error While generating ios app in OS10

Forge Component
(6)
Published on 18 Jul by Experts
6 votes
Published on 18 Jul by Experts

Hello,

Currently when we generate the app for IOS we are getting below error. Could you please update the plugin?

[ERROR]
You have been opted out of telemetry. To change this, run: cordova telemetry on.
No scripts found for hook "before_plugin_add".
Calling plugman.fetch on plugin "https://github.com/OutSystemsExperts/outsystems-phonegap-plugin-push.git#2.2.3-os"
Fetching plugin "https://github.com/OutSystemsExperts/outsystems-phonegap-plugin-push.git" via git clone
Running command: git clone https://github.com/OutSystemsExperts/outsystems-phonegap-plugin-push.git /var/folders/gq/90w3r_pd0wnbnh1fyl6qtt0c0000gr/T/git/1553800234184
Command finished with error code 0: git clone,https://github.com/OutSystemsExperts/outsystems-phonegap-plugin-push.git,/var/folders/gq/90w3r_pd0wnbnh1fyl6qtt0c0000gr/T/git/1553800234184
Running command: git checkout 2.2.3-os
Command finished with error code 0: git checkout,2.2.3-os
Repository "https://github.com/OutSystemsExperts/outsystems-phonegap-plugin-push.git" checked out to git ref "2.2.3-os".
/tmp/build/source/plugins/phonegap-plugin-push"...
Plugin "phonegap-plugin-push" fetched.
Calling plugman.install on plugin "/Users/mabs02/NativeBuilder/builds/e65b3bd3-3b1e-43b1-9739-be2ac69c34bc/source/plugins/phonegap-plugin-push" for platform "ios
Installing "phonegap-plugin-push" for ios
Running command: /Users/mabs02/NativeBuilder/builds/e65b3bd3-3b1e-43b1-9739-be2ac69c34bc/source/platforms/ios/cordova/version
Command finished with error code 0: /Users/mabs02/NativeBuilder/builds/e65b3bd3-3b1e-43b1-9739-be2ac69c34bc/source/platforms/ios/cordova/version
Finding scripts for "before_plugin_install" hook from plugin phonegap-plugin-push on ios platform only.
Executing script found in plugin phonegap-plugin-push for hook "before_plugin_install": plugins/phonegap-plugin-push/hooks/outsystems/install_prerequisites.js
Running hook to install push notifications pre-requisites
Resolving module name for child_process => child_process
Resolving module name for q => q
Executing script found in plugin phonegap-plugin-push for hook "before_plugin_install": plugins/phonegap-plugin-push/hooks/outsystems/unzip_google_service_config.js
Resolving module name for q => q
Resolving module name for fs => fs
Resolving module name for path => path
Resolving module name for cordova-common => cordova-common
Executing script found in plugin phonegap-plugin-push for hook "before_plugin_install": plugins/phonegap-plugin-push/hooks/outsystems/copy_google_service_config.js
Resolving module name for q => q
Resolving module name for fs => fs
Resolving module name for path => path
Resolving module name for cordova-common => cordova-common
Error: Path must be a string. Received undefined

[2019-03-28T19:10:46.230Z] [ERROR] Build failed with the following error: An unexpected error has occurred while installing the Cordova plugins. Please try again. If the problem persists, contact OutSystems Support.

Hi,

Try with this approach for test purpose to identify the issue:

Make a Local Copy of the Plugin & Goto Configuration, Update the Consumed URL with the latest version using #.

thanks

Hi,

Not sure what you meant, I have no clue about how to build an app in cordova or anything related to cordova. Lot more explanation would be helpful. 

Prasad Rao wrote:

Hi,

Not sure what you meant, I have no clue about how to build an app in cordova or anything related to cordova. Lot more explanation would be helpful. 

You need to Clone the Module i.e Plugin.