Error and General Logs Not Appearing

Hello,

I'm using OutSystems 10 and no Error Logs or General Logs are appearing on Service Center, only the errors and general logs of the eSpace System what's really weird. Any hints in how to fix this?

Thank you.

Hi Tiago,

Are you really sure you don't have set a filter on (System)? ;)

100% sure. I've tested that already.

So you filter looks like this?

In that case, how many modules do you have installed on that environment? Are they published correctly? Are they being used at all? Is the Auditing option checked on the Operation tab of each eSpace?

Yes. Everything is like that. I've double checked those options already. Only the System Errors are appearing, all the rest is not appearing. This is a new server that we have, on the others is everything working properly. Only this one we cannot see the logs. I also checked the database tables and I just have there the logs of the System eSpace.

Solution

Hi Tiago,


If I understood correctly you only miss the errors for the new server, for the old ones everything working as expected. Is that correct?


Could you check if MSMQ has been correctly installed? Also, could you try restarting "OutSystems Log" service in the new server? If that does not work check the event viewer (system and application) for hints. If after that you can´t sort it out you should open a support case.


Ivo

Solution

Hi Tiago

Are the old servers and the new one part of the same Environment? or different Environments?

This may sound dumb but... do you have any applications installed that would generate logs? could you try logging in to the Users app and see if any logs are generated in the General logs tab?

Like Ivo suggested, this could also be a problem with the OutSystems Log service so if this is an on premises installation, you could check on Windows Event Viewer of the new Server if there are any errors being logged there by the OutSystems' services.

Hello Ivo and Jorge,

I've restarted the OutSystems Logs service but without success. However, like you suggested I've checked the Windows Event Viewer and the errors are being logged there, but they still don't appear on Service Center. Any ideia why or how to fix this? I believe that during the setup didn't come up anything to configure this.

Thank you in advance.

Hi,


- what role do you have in lifetime, because that might be also preventing you to see the logging.

- is there actually data in the log-table )do a test-query on the systems tables)



Hello J.,

I got Administrator role on Lifetime and on System Tables I just got logged the logs of the eSpace with ID 1 which is the System.

Thank you :(

Tiago,

What kind of errors are you seeing on the Windows Event Viewer?

Hello. It was missing the instalation of a Feature on the server about the Message Queuing Server. After the instalation I just rebooted the OutSystems Log Service and worked properly after few seconds. Thank you all for your help.

Great to hear you got it solved Tiago.