Chart changes everytime i go back and forth [Mobile]

^(First time i go in and this datapoint is correct)

^(next time i go in and the datapoint on the right is right but on the left 27.27 is wrong)


I suspect that it's the OnAfterFetch event screwing this up and thus I'm trying to find a way to not leave footprints via OnDestroy(Which i cant figure out how to do).

And this only happens when i press back or next into this page; otherwise the data is fine (20 on 2019-04-08)

Any suggestions?

So far I've placed designation buttons and an alert message to prevent people from using back/next on screens to protect chart's integrity....


Two suggestions:

  1. Check Service Center to see if there are any error messages that might indicate something related to the issue.
  2. Create a new project with the smallest possible demo that reproduces the issue, and share that here, which may help a lot in troubleshooting. 

G. Andrew Duthie wrote:

Two suggestions:

  1. Check Service Center to see if there are any error messages that might indicate something related to the issue.
  2. Create a new project with the smallest possible demo that reproduces the issue, and share that here, which may help a lot in troubleshooting. 

1) 

How do i do the OnDestroy thingy?

2)Hi, attached is a sample OML of exactly what i am experiencing. Datapoints have been input. Try using your PC's emulator and use the native buttons on ur computer to travel btwn screens and you'll see what i mean.

If using an onscreen button to travel to a chart page it'll fetch just fine


G. Andrew Duthie wrote:

Two suggestions:

  1. Check Service Center to see if there are any error messages that might indicate something related to the issue.
  2. Create a new project with the smallest possible demo that reproduces the issue, and share that here, which may help a lot in troubleshooting. 

I've managed to fix it by implementing https://www.outsystems.com/forge/component-overview/4760/android-back-button-key and overriding what the android back button does.

Instead of NavigatingBack i specify to a designated screen which solves this issue.

Is there a way i can raise this phenomenon to the developers?


"Is there a way i can raise this phenomenon to the developers?"

https://www.outsystems.com/forge/component-discussions/4141/Charts+Mobile

is the best place to post issues that you find with the Charts Mobile component.